<!DOCTYPE html>
<!--[if IE 8]>
<html class="ie8" lang="en-US">
<![endif]-->
<!--[if gt IE 8]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta property="twitter:account_id" content="16227829"/>
<meta charset="UTF-8"/>
<meta name="viewport" content="width=device-width"/>
<title>vSphere Content Library PowerCLI community module | virtuallyGhetto</title>
<link rel="profile" href="http://gmpg.org/xfn/11"/>
<link rel="pingback" href="http://www.virtuallyghetto.com/xmlrpc.php"/>
<link href="https://fonts.googleapis.com/css?family=Roboto+Slab:300,400,700,100" rel='stylesheet' type='text/css'>
<link rel='dns-prefetch' href='//www.virtuallyghetto.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//w.sharethis.com'/>
<link rel='dns-prefetch' href='//s.gravatar.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="virtuallyGhetto &raquo; Feed" href="http://www.virtuallyghetto.com/feed"/>
<link rel="alternate" type="application/rss+xml" title="virtuallyGhetto &raquo; Comments Feed" href="http://www.virtuallyghetto.com/comments/feed"/>
<link rel="alternate" type="application/rss+xml" title="virtuallyGhetto &raquo; vSphere Content Library PowerCLI community module Comments Feed" href="http://www.virtuallyghetto.com/2017/07/vsphere-content-library-powercli-community-module.html/feed"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.virtuallyghetto.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='crayon-css' href='http://www.virtuallyghetto.com/wp-content/plugins/crayon-syntax-highlighter/css/min/crayon.min.css?ver=_2.7.2_beta' type='text/css' media='all'/>
<link rel='stylesheet' id='easy_author_image-css' href='http://www.virtuallyghetto.com/wp-content/plugins/easy-author-image/css/easy-author-image.css?ver=4.8' type='text/css' media='all'/>
<link rel='stylesheet' id='m1-style-css' href='http://www.virtuallyghetto.com/wp-content/themes/m1/style.css?ver=4.8' type='text/css' media='all'/>
<link rel='stylesheet' id='simple-social-icons-font-css' href='http://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/css/style.css?ver=2.0.1' type='text/css' media='all'/>
<link rel='stylesheet' id='slb_core-css' href='http://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.6.0' type='text/css' media='all'/>
<link rel='stylesheet' id='easy_table_style-css' href='http://www.virtuallyghetto.com/wp-content/plugins/easy-table/themes/cuscosky/style.css?ver=1.6' type='text/css' media='all'/>
<link rel='stylesheet' id='jetpack_css-css' href='http://www.virtuallyghetto.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.1' type='text/css' media='all'/>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var CrayonSyntaxSettings = {"version":"_2.7.2_beta","is_admin":"0","ajaxurl":"http:\/\/www.virtuallyghetto.com\/wp-admin\/admin-ajax.php","prefix":"crayon-","setting":"crayon-setting","selected":"crayon-setting-selected","changed":"crayon-setting-changed","special":"crayon-setting-special","orig_value":"data-orig-value","debug":""};
var CrayonSyntaxStrings = {"copy":"Press %s to Copy, %s to Paste","minimize":"Click To Expand Code"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/plugins/crayon-syntax-highlighter/js/min/crayon.min.js?ver=_2.7.2_beta'></script>
<script id='st_insights_js' type='text/javascript' src="https://ws.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare"></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/themes/m1/js/modernizr.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/themes/m1/js/off-canvas-nav-simple.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/themes/m1/js/superfish.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script>
<script type="text/javascript">
	!function(){var analytics=window.analytics=window.analytics||[];if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["trackSubmit","trackClick","trackLink","trackForm","pageview","identify","group","track","ready","alias","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="3.0.0";
		window.analytics.load("87b6nylkx2");
	window.analytics.page();
	  }}();
</script>
<link rel='https://api.w.org/' href='http://www.virtuallyghetto.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.virtuallyghetto.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.virtuallyghetto.com/wp-includes/wlwmanifest.xml"/>
<link rel='prev' title='Using vSphere Guest Operations API on macOS Guests? ' href='http://www.virtuallyghetto.com/2017/07/using-vsphere-guest-operations-api-on-macos-guests.html'/>
<meta name="generator" content="WordPress 4.8"/>
<link rel="canonical" href="http://www.virtuallyghetto.com/2017/07/vsphere-content-library-powercli-community-module.html"/>
<link rel='shortlink' href='http://wp.me/p4ymB2-Fcv'/>
<link rel="alternate" type="application/json+oembed" href="http://www.virtuallyghetto.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.virtuallyghetto.com%2F2017%2F07%2Fvsphere-content-library-powercli-community-module.html"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.virtuallyghetto.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.virtuallyghetto.com%2F2017%2F07%2Fvsphere-content-library-powercli-community-module.html&#038;format=xml"/>
 
<script type="text/javascript">
        (function(){
          var bsa = document.createElement('script');
              bsa.type= 'text/javascript';
              bsa.async = true;
              bsa.src='//s3.buysellads.com/ac/bsa.js';
          (document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(bsa);
        })();
        </script>
 
<script>(function(d, s, id){
                 var js, fjs = d.getElementsByTagName(s)[0];
                 if (d.getElementById(id)) {return;}
                 js = d.createElement(s); js.id = id;
                 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
                 fjs.parentNode.insertBefore(js, fjs);
               }(document, 'script', 'facebook-jssdk'));</script><style type="text/css">.ssba{}.ssba img{width:35px!important;padding:6px;border:0;box-shadow:none!important;display:inline!important;vertical-align:middle;}.ssba,.ssba a{text-decoration:none;border:0;background:none;font-size:20px;}</style><script type="text/javascript">
	window._wp_rp_static_base_url = 'https://wprp.zemanta.com/static/';
	window._wp_rp_wp_ajax_url = "http://www.virtuallyghetto.com/wp-admin/admin-ajax.php";
	window._wp_rp_plugin_version = '3.6.4';
	window._wp_rp_post_id = '158379';
	window._wp_rp_num_rel_posts = '6';
	window._wp_rp_thumbnails = false;
	window._wp_rp_post_title = 'vSphere+Content+Library+PowerCLI+community+module';
	window._wp_rp_post_tags = ['content+library', 'powercli', 'powercli', 'automation', 'content', 'show', 'librari', 'modul', 'search', 'api', 'a', 'ci', 'web', 'box', 'work', 'vsphere', 'alt', 'commun', 'server'];
	window._wp_rp_promoted_content = true;
</script>
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<script type="text/javascript">
    jQuery(document).ready(function($) {
                $('nav ul.menu').superfish({
                        hoverClass:  'sfHover',
                        disableHI:   true,
                        delay:       0,                               // no delay on mouseout
                        animation:   {opacity:'show',height:'show'},  // fade-in and slide-down animation
                        speed:       'fast',                          // faster animation speed
                        cssArrows:   true                             // arrows
                });
        });
  </script>
<style type="text/css" media="screen">.simple-social-icons ul li a,.simple-social-icons ul li a:hover,.simple-social-icons ul li a:focus{background-color:#999999!important;border-radius:4px;color:#ffffff!important;border:0px #ffffff solid!important;font-size:18px;padding:9px;}.simple-social-icons ul li a:hover,.simple-social-icons ul li a:focus{background-color:#a02724!important;border-color:#ffffff!important;color:#ffffff!important;}.simple-social-icons ul li a:focus{outline:1px dotted #a02724!important;}</style>
 
<meta property="og:type" content="article"/>
<meta property="og:title" content="vSphere Content Library PowerCLI community module"/>
<meta property="og:url" content="http://www.virtuallyghetto.com/2017/07/vsphere-content-library-powercli-community-module.html"/>
<meta property="og:description" content="I was recently doing some work with the vSphere Content Library and I needed to extract some information using the Content Library API. I was hoping there were a few out of the box PowerCLI cmdlets…"/>
<meta property="article:published_time" content="2017-07-06T15:23:52+00:00"/>
<meta property="article:modified_time" content="2017-07-06T15:23:52+00:00"/>
<meta property="og:site_name" content="virtuallyGhetto"/>
<meta property="og:image" content="http://www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-2.png"/>
<meta property="og:image:width" content="706"/>
<meta property="og:image:height" content="370"/>
<meta property="og:locale" content="en_US"/>
<meta name="twitter:card" content="summary"/>
<link rel="icon" href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=32%2C32" sizes="32x32"/>
<link rel="icon" href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=192%2C192" sizes="192x192"/>
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=180%2C180"/>
<meta name="msapplication-TileImage" content="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=240%2C240"/>
<link rel="stylesheet" type="text/css" id="wp-custom-css" href="http://www.virtuallyghetto.com/?custom-css=87480a5188"/>
<style>.top-menu-container,.top-menu ul ul,.navigation-main ul ul,.navigation-main li.sfHover:hover{background-color:#ffffff;}.top-menu a,.top-menu ul ul a,.navigation-main a,.navigation-main ul ul a,.navigation-main li.sfHover a,.m1-social-icons a{color:#0a0a0a;}</style>
</head>
<body class="post-template-default single single-post postid-158379 single-format-standard">
<div id="page" class="hfeed site">
<header id="masthead" class="site-header" role="banner">
<section class="top-menu-container">
<div class="top-menu-inside">
<div class="m1-social-icons">
</div>
</div>
</section>
<section class="site-branding">
<a class="nav-btn" id="nav-open-btn">Menu</a>
<div class="site-title-wrap">
<hgroup>
<h1 class="site-title"><a href="http://www.virtuallyghetto.com/" title="virtuallyGhetto" rel="home">virtuallyGhetto</a></h1>
<p class="site-description"></p>
</hgroup>
</div> 
<div id="header-widget-area">
</div>
<nav id="site-navigation" class="navigation-main" role="navigation">
<a class="close-btn" id="nav-close-btn">Close Menu</a>
<div class="screen-reader-text skip-link"><a href="#content" title="Skip to content">Skip to content</a></div>
<div class="menu-main-container"><ul id="menu-main" class="menu"><li id="menu-item-510" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-510"><a href="http://www.virtuallyghetto.com/about">About</a></li>
<li id="menu-item-760" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-760"><a href="#">Automation</a>
<ul class="sub-menu">
<li id="menu-item-591" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-591"><a href="http://www.virtuallyghetto.com/vmware-kickstart">VMware Kickstart</a></li>
<li id="menu-item-593" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-593"><a href="http://www.virtuallyghetto.com/kickstart">VMware API/SDK/CLI</a></li>
<li id="menu-item-592" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-592"><a href="http://www.virtuallyghetto.com/vmware-vmavima">VMware vMA/VIMA</a></li>
<li id="menu-item-13682" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13682"><a href="http://www.virtuallyghetto.com/ovf">VMware OVF / OVFTOOL</a></li>
</ul>
</li>
<li id="menu-item-448" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-448"><a href="http://www.virtuallyghetto.com/apple">Apple Mac Mini/Pro</a></li>
<li id="menu-item-450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-450"><a href="http://www.virtuallyghetto.com/nested-virtualization">Nested Virtualization</a></li>
<li id="menu-item-449" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-449"><a href="http://www.virtuallyghetto.com/vcsa">VCSA</a></li>
<li id="menu-item-10631" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10631"><a href="http://www.virtuallyghetto.com/vsan">VSAN</a></li>
</ul></div> </nav> 
</section> 
</header> 
<div id="main" class="site-main">
<header class="entry-header">
<h1 class="page-title">vSphere Content Library PowerCLI community module</h1>
</header>
<div id="primary" class="content-area">
<div id="content" class="site-content" role="main">
<article id="post-158379" class="post-158379 post type-post status-publish format-standard hentry category-automation category-powercli tag-content-library tag-powercli">
<div class="entry-meta">
Posted on <a href="http://www.virtuallyghetto.com/2017/07/vsphere-content-library-powercli-community-module.html" title="8:23 am" rel="bookmark"><time class="entry-date" datetime="2017-07-06T08:23:52+00:00">07/06/2017</time></a><span class="byline"> by <span class="author vcard"><a class="url fn n" href="http://www.virtuallyghetto.com/author/lamw" title="View all posts by William Lam" rel="author">William Lam</a></span></span> </div> 
<div class="entry-content">
<p>I was recently doing some work with the vSphere Content Library and I needed to extract some information using the <a href="https://code.vmware.com/apis/52/content" target="_blank" rel="noopener">Content Library API</a>. I was hoping there were a few out of the box PowerCLI cmdlets but to my surprise, there was only one cmdlet called Get-ContentLibraryItem which did not get into the level of details that I was looking for, which was on a per-file level rather than item-level. I had also search the web to see if anyone had built any functions and although a few existed, none that did the very basics which was retrieving all libraries, library items and library item files.</p>
<p>Not having worked with the Content Library APIs before, I figure this would be a good learning opportunity and created a PowerCLI module called <a href="https://github.com/lamw/PowerCLI-Example-Scripts/blob/master/Modules/ContentLibrary/ContentLibrary.psm1" target="_blank" rel="noopener"><strong>ContentLibrary.psm1</strong></a> which contains the following functions:</p>
<ul>
<li><strong>Get-ContentLibrary</strong></li>
<li><strong>Get-ContentLibraryItems</strong></li>
<li><strong>Get-ContentLibraryItemFiles</strong></li>
</ul>
<p>Before you can make use of these functions, make sure to connect to the CIS endpoint of your vCenter Server using the Connect-CisServer cmdlet.</p>
<p>Here is a screenshot of the vSphere Web Client showing all available Content Libraries:</p>
<p><a href="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-1.png" data-slb-active="1" data-slb-asset="2092355896" data-slb-internal="0" data-slb-group="158379"><img data-attachment-id="158395" data-permalink="http://www.virtuallyghetto.com/2017/07/vsphere-content-library-powercli-community-module.html/vsphere-content-library-powercli-module-1#main" data-orig-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-1.png?fit=1259%2C208" data-orig-size="1259,208" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="vsphere-content-library-powercli-module-1" data-image-description="" data-medium-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-1.png?fit=300%2C50" data-large-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-1.png?fit=770%2C127" class="alignnone size-full wp-image-158395" src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-1.png?resize=770%2C127" alt="" data-recalc-dims="1"/></a><br/>
Here is an example of retrieving the same information using the following command:</p>
<p class="terminal">Get-ContentLibrary</p>
<p><a href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-2.png" data-slb-active="1" data-slb-asset="198817441" data-slb-internal="0" data-slb-group="158379"><img data-attachment-id="158381" data-permalink="http://www.virtuallyghetto.com/2017/07/vsphere-content-library-powercli-community-module.html/vsphere-content-library-powercli-module-2#main" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-2.png?fit=706%2C370" data-orig-size="706,370" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="vsphere-content-library-powercli-module-2" data-image-description="" data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-2.png?fit=300%2C157" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-2.png?fit=706%2C370" class="alignnone size-full wp-image-158381" src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-2.png?resize=706%2C370" alt="" data-recalc-dims="1"/></a><br/>
<span style="color: #ff0000;"><strong>Note:</strong></span> You also have the ability to filter for the name of a specific Content Library by using the <strong>-LibraryName</strong> parameter</p>
<p>Here is a screenshot of the vSphere Web Client showing the individual Items within a Content Library:</p>
<p><a href="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-3.png" data-slb-active="1" data-slb-asset="1749493423" data-slb-internal="0" data-slb-group="158379"><img data-attachment-id="158396" data-permalink="http://www.virtuallyghetto.com/2017/07/vsphere-content-library-powercli-community-module.html/vsphere-content-library-powercli-module-3#main" data-orig-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-3.png?fit=1168%2C239" data-orig-size="1168,239" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="vsphere-content-library-powercli-module-3" data-image-description="" data-medium-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-3.png?fit=300%2C61" data-large-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-3.png?fit=770%2C158" class="alignnone size-full wp-image-158396" src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-3.png?resize=770%2C158" alt="" data-recalc-dims="1"/></a><br/>
Here is an example of retrieving the same information using the following command:</p>
<p class="terminal">Get-ContentLibraryItems -LibraryName Test</p>
<p><a href="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-4.png" data-slb-active="1" data-slb-asset="724122470" data-slb-internal="0" data-slb-group="158379"><img data-attachment-id="158382" data-permalink="http://www.virtuallyghetto.com/2017/07/vsphere-content-library-powercli-community-module.html/vsphere-content-library-powercli-module-4#main" data-orig-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-4.png?fit=791%2C439" data-orig-size="791,439" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="vsphere-content-library-powercli-module-4" data-image-description="" data-medium-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-4.png?fit=300%2C166" data-large-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-4.png?fit=770%2C427" class="alignnone size-full wp-image-158382" src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-4.png?resize=770%2C427" alt="" data-recalc-dims="1"/></a><br/>
<span style="color: #ff0000;"><strong>Note:</strong> </span>You also have the ability to filter for the name of a specific Content Library Item by using the <strong>-LibraryItemName</strong> parameter</p>
<p>Although the granularity when using the vSphere Web Client is at a Content Library Item, using the Content Library API, you can get additional information on the Item itself which is then composed of a set of files. The following command will allow you to retrieve all Files or you can use <strong>-LibraryItemName</strong> parameter to filter on a specific Item.</p>
<p class="terminal">Get-ContentLibraryItemFiles -LibraryName Test -LibraryItemName TinyVM</p>
<p><a href="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-5.png" data-slb-active="1" data-slb-asset="221610508" data-slb-internal="0" data-slb-group="158379"><img data-attachment-id="158383" data-permalink="http://www.virtuallyghetto.com/2017/07/vsphere-content-library-powercli-community-module.html/vsphere-content-library-powercli-module-5#main" data-orig-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-5.png?fit=1101%2C155" data-orig-size="1101,155" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="vsphere-content-library-powercli-module-5" data-image-description="" data-medium-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-5.png?fit=300%2C42" data-large-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-5.png?fit=770%2C108" class="alignnone size-full wp-image-158383" src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/07/vsphere-content-library-powercli-module-5.png?resize=770%2C108" alt="" data-recalc-dims="1"/></a></p>
<div class="wp_rp_wrap  wp_rp_vertical_m" id="wp_rp_first"><div class="wp_rp_content"><h3 class="related_post_title">More from my site</h3><ul class="related_post wp_rp"><li data-position="0" data-poid="in-21303" data-post-type="none"><a href="http://www.virtuallyghetto.com/2017/01/exploring-new-vcsa-vami-api-wpowercli-part-1.html" class="wp_rp_title">Exploring new VCSA VAMI API w/PowerCLI: Part 1</a></li><li data-position="1" data-poid="in-21690" data-post-type="none"><a href="http://www.virtuallyghetto.com/2017/02/exploring-new-vcsa-vami-api-wpowercli-part-8.html" class="wp_rp_title">Exploring new VCSA VAMI API w/PowerCLI: Part 8</a></li><li data-position="2" data-poid="in-22754" data-post-type="none"><a href="http://www.virtuallyghetto.com/2017/04/managing-silencing-vsan-health-checks-using-powercli.html" class="wp_rp_title">Managing &#038; silencing vSAN Health Checks using PowerCLI</a></li><li data-position="3" data-poid="in-21701" data-post-type="none"><a href="http://www.virtuallyghetto.com/2017/03/exploring-new-vcsa-vami-api-wpowercli-part-9.html" class="wp_rp_title">Exploring new VCSA VAMI API w/PowerCLI: Part 9</a></li><li data-position="4" data-poid="in-21545" data-post-type="none"><a href="http://www.virtuallyghetto.com/2017/02/exploring-new-vcsa-vami-api-wpowercli-part-7.html" class="wp_rp_title">Exploring new VCSA VAMI API w/PowerCLI: Part 7</a></li><li data-position="5" data-poid="in-22586" data-post-type="none"><a href="http://www.virtuallyghetto.com/2017/04/getting-started-wthe-new-powercli-6-5-1-get-vsanview-cmdlet.html" class="wp_rp_title">Getting started w/the new PowerCLI 6.5.1 Get-VsanView cmdlet</a></li></ul></div></div>
 <div class="ssba ssba-wrap"><div style="text-align:left"><a href="https://simplesharebuttons.com" target="_blank">Be Sociable, Share</a><a data-site="" class="ssba_twitter_share" href="https://twitter.com/share?url=http://www.virtuallyghetto.com/2017/07/vsphere-content-library-powercli-community-module.html&amp;text=vSphere+Content+Library+PowerCLI+community+module+" target="_blank"><img src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/twitter.png?w=770" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" data-recalc-dims="1"/></a><a data-site="" class="ssba_facebook_share" href="https://www.facebook.com/sharer.php?u=http://www.virtuallyghetto.com/2017/07/vsphere-content-library-powercli-community-module.html" target="_blank"><img src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/facebook.png?w=770" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" data-recalc-dims="1"/></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=http://www.virtuallyghetto.com/2017/07/vsphere-content-library-powercli-community-module.html" target="_blank"><img src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/linkedin.png?w=770" title="LinkedIn" class="ssba ssba-img" alt="Share on LinkedIn" data-recalc-dims="1"/></a><a data-site="" class="ssba_google_share" href="https://plus.google.com/share?url=http://www.virtuallyghetto.com/2017/07/vsphere-content-library-powercli-community-module.html" target="_blank"><img src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/google.png?w=770" title="Google+" class="ssba ssba-img" alt="Share on Google+" data-recalc-dims="1"/></a><a data-site='pinterest' class='ssba_pinterest_share' href='javascript:void((function()%7Bvar%20e=document.createElement(&apos;script&apos;);e.setAttribute(&apos;type&apos;,&apos;text/javascript&apos;);e.setAttribute(&apos;charset&apos;,&apos;UTF-8&apos;);e.setAttribute(&apos;src&apos;,&apos;//assets.pinterest.com/js/pinmarklet.js?r=&apos;+Math.random()*99999999);document.body.appendChild(e)%7D)());'><img src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/pinterest.png?w=770" title="Pinterest" class="ssba ssba-img" alt="Pin on Pinterest" data-recalc-dims="1"/></a><a data-site="reddit" class="ssba_reddit_share" href="https://reddit.com/submit?url=http://www.virtuallyghetto.com/2017/07/vsphere-content-library-powercli-community-module.html&amp;title=vSphere Content Library PowerCLI community module" target="_blank"><img src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/reddit.png?w=770" title="Reddit" class="ssba ssba-img" alt="Share on Reddit" data-recalc-dims="1"/></a></div></div> </div> 
<footer class="entry-meta">
Category: <a href="http://www.virtuallyghetto.com/category/automation" rel="category tag">Automation</a>, <a href="http://www.virtuallyghetto.com/category/powercli" rel="category tag">PowerCLI</a> Tags: <a href="http://www.virtuallyghetto.com/tag/content-library" rel="tag">content library</a>, <a href="http://www.virtuallyghetto.com/tag/powercli" rel="tag">powercli</a>
</footer> 
</article> 
<nav role="navigation" id="nav-below" class="navigation-post">
<h1 class="screen-reader-text">Post navigation</h1>
<div class="nav-previous"><a href="http://www.virtuallyghetto.com/2017/07/using-vsphere-guest-operations-api-on-macos-guests.html" rel="prev"><span class="meta-nav">&larr;</span> Using vSphere Guest Operations API on macOS Guests? </a></div>
</nav> 
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Thanks for the comment! <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/07/vsphere-content-library-powercli-community-module.html#respond" style="display:none;">Cancel reply</a></small></h3>
<form id="commentform" class="comment-form">
<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=67295360&#038;postid=158379&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=retro&#038;greeting=Thanks+for+the+comment%21&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=5.1&#038;sig=35aec5ce022d6d63a23a02461b97bbb6d8a064d3#parent=http%3A%2F%2Fwww.virtuallyghetto.com%2F2017%2F07%2Fvsphere-content-library-powercli-community-module.html" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
<!--[if !IE]><!-->
<script>
					document.addEventListener( 'DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName( 'jetpack_remote_comment' );
						for ( var i = 0; i < commentForms.length; i++ ) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					} );
				</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value=""/>
</div> 
</div> 
</div> 
<div id="secondary" class="widget-area" role="complementary">
<aside id="text-5" class="widget widget_text"> <div class="textwidget"><div class="circular_author"></div>
<center><b>William Lam</b></center></div>
</aside><aside id="simple-social-icons-4" class="widget simple-social-icons"><ul class="aligncenter"><li class="ssi-github"><a href="https://github.com/lamw" target="_blank"><svg role="img" class="social-github" aria-labelledby="social-github"><title id="social-github">Github</title><use xlink:href="http://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-github"></use></svg></a></li><li class="ssi-gplus"><a href="https://plus.google.com/114142893306148938477" target="_blank"><svg role="img" class="social-gplus" aria-labelledby="social-gplus"><title id="social-gplus">Google+</title><use xlink:href="http://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-gplus"></use></svg></a></li><li class="ssi-linkedin"><a href="https://www.linkedin.com/in/lamwilliam/" target="_blank"><svg role="img" class="social-linkedin" aria-labelledby="social-linkedin"><title id="social-linkedin">Linkedin</title><use xlink:href="http://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-linkedin"></use></svg></a></li><li class="ssi-rss"><a href="http://www.virtuallyghetto.com/rss" target="_blank"><svg role="img" class="social-rss" aria-labelledby="social-rss"><title id="social-rss">RSS</title><use xlink:href="http://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-rss"></use></svg></a></li><li class="ssi-twitter"><a href="https://twitter.com/lamw" target="_blank"><svg role="img" class="social-twitter" aria-labelledby="social-twitter"><title id="social-twitter">Twitter</title><use xlink:href="http://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li></ul></aside><aside id="search-5" class="widget widget_search"> <form method="get" id="searchform" class="searchform" action="http://www.virtuallyghetto.com/" role="search">
<label for="s" class="screen-reader-text">Search</label>
<input type="search" class="field" name="s" value="" id="s" placeholder="Search &hellip;"/>
<input type="submit" class="submit" id="searchsubmit" value="Search"/>
</form>
</aside><aside id="bsa-6" class="widget widget_bsa">
 
<div id="bsap_1282588" class="bsarocks bsap_6d274f0434e88e8f84574d74902bc1c4"></div>
 
</aside> </div> 
</div> 
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="site-info">
<a href="https://wordpress.org/" title="A Semantic Personal Publishing Platform" rel="generator">Proudly powered by WordPress</a>
<span class="sep"> | </span>
Theme: m1 Theme by <a href="http://m1themes.com" title="m1 Themes" rel="designer">m1 Themes</a>. </div> 
</footer> 
</div> 
<script type="text/javascript">
  analytics.track("Viewed Post", {"title":"vSphere Content Library PowerCLI community module","category":"Automation, PowerCLI","noninteraction":true}, {"library":"analytics-wordpress"});
    
</script>
<div style="display:none">
</div>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3.2'></script>
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='http://www.virtuallyghetto.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201727'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.min.js?ver=4.8'></script>
<script type='text/javascript' src="https://s.gravatar.com/js/gprofiles.js?ver=2017Julaa"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/themes/m1/js/skip-link-focus-fix.js?ver=20130115'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-includes/js/comment-reply.min.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-includes/js/wp-embed.min.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/spin.js?ver=1.3'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/jquery.spin.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/www.virtuallyghetto.com\/wp-admin\/admin-ajax.php","nonce":"0f8a89b9b0","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"http:\/\/www.virtuallyghetto.com\/wp-login.php?redirect_to=http%3A%2F%2Fwww.virtuallyghetto.com%2F2017%2F07%2Fvsphere-content-library-powercli-community-module.html","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.js?ver=20170209'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/client/js/prod/lib.core.js?ver=2.6.0'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/client/js/prod/lib.view.js?ver=2.6.0'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/themes/baseline/js/prod/client.js?ver=2.6.0'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/themes/default/js/prod/client.js?ver=2.6.0'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/template-tags/item/js/prod/tag.item.js?ver=2.6.0'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/template-tags/ui/js/prod/tag.ui.js?ver=2.6.0'></script>
<script type='text/javascript' src='http://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/content-handlers/image/js/prod/handler.image.js?ver=2.6.0'></script>
<script type="text/javascript" id="slb_footer">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</script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=67295360&postid=158379&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=retro&greeting=Thanks+for+the+comment%21&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.1&sig=35aec5ce022d6d63a23a02461b97bbb6d8a064d3#parent=http%3A%2F%2Fwww.virtuallyghetto.com%2F2017%2F07%2Fvsphere-content-library-powercli-community-module.html" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=67295360&postid=158379&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=retro&greeting=Thanks+for+the+comment%21&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.1&sig=35aec5ce022d6d63a23a02461b97bbb6d8a064d3#parent=http%3A%2F%2Fwww.virtuallyghetto.com%2F2017%2F07%2Fvsphere-content-library-powercli-community-module.html";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "http:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "http:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>
<script type='text/javascript' src='https://stats.wp.com/e-201727.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.1',blog:'67295360',post:'158379',tz:'-7',srv:'www.virtuallyghetto.com'} ]);
	_stq.push([ 'clickTrackerInit', '67295360', '158379' ]);
</script>
</body>
</html>
 