<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Customizing the NSX-T Login UI</title>
<script>(function(d, s, id){
				 var js, fjs = d.getElementsByTagName(s)[0];
				 if (d.getElementById(id)) {return;}
				 js = d.createElement(s); js.id = id;
				 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
				 fjs.parentNode.insertBefore(js, fjs);
			   }(document, 'script', 'facebook-jssdk'));</script><link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//ws.sharethis.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="virtuallyGhetto &raquo; Feed" href="https://www.virtuallyghetto.com/feed" />
<link rel="alternate" type="application/rss+xml" title="virtuallyGhetto &raquo; Comments Feed" href="https://www.virtuallyghetto.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="virtuallyGhetto &raquo; Customizing the NSX-T Login UI Comments Feed" href="https://www.virtuallyghetto.com/2019/10/customizing-the-nsx-t-login-ui.html/feed" />
<link rel="canonical" href="https://www.virtuallyghetto.com/2019/10/customizing-the-nsx-t-login-ui.html" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.virtuallyghetto.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='crayon-css' href='https://www.virtuallyghetto.com/wp-content/plugins/crayon-syntax-highlighter/css/min/crayon.min.css?ver=_2.7.2_beta' type='text/css' media='all' />
<link rel='stylesheet' id='crayon-theme-tomorrow-night-css' href='https://www.virtuallyghetto.com/wp-content/plugins/crayon-syntax-highlighter/themes/tomorrow-night/tomorrow-night.css?ver=_2.7.2_beta' type='text/css' media='all' />
<link rel='stylesheet' id='crayon-font-monaco-css' href='https://www.virtuallyghetto.com/wp-content/plugins/crayon-syntax-highlighter/fonts/monaco.css?ver=_2.7.2_beta' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-sample-css' href='https://www.virtuallyghetto.com/wp-content/themes/genesis-sample/style.css?ver=2.6.0' type='text/css' media='all' />
<style id='genesis-sample-inline-css' type='text/css'>


		a,
		.entry-title a:focus,
		.entry-title a:hover,
		.genesis-nav-menu a:focus,
		.genesis-nav-menu a:hover,
		.genesis-nav-menu .current-menu-item > a,
		.genesis-nav-menu .sub-menu .current-menu-item > a:focus,
		.genesis-nav-menu .sub-menu .current-menu-item > a:hover,
		.menu-toggle:focus,
		.menu-toggle:hover,
		.sub-menu-toggle:focus,
		.sub-menu-toggle:hover {
			color: #830101;
		}

		

		button:focus,
		button:hover,
		input[type="button"]:focus,
		input[type="button"]:hover,
		input[type="reset"]:focus,
		input[type="reset"]:hover,
		input[type="submit"]:focus,
		input[type="submit"]:hover,
		input[type="reset"]:focus,
		input[type="reset"]:hover,
		input[type="submit"]:focus,
		input[type="submit"]:hover,
		.button:focus,
		.button:hover,
		.genesis-nav-menu > .menu-highlight > a:hover,
		.genesis-nav-menu > .menu-highlight > a:focus,
		.genesis-nav-menu > .menu-highlight.current-menu-item > a {
			background-color: #830101;
			color: #ffffff;
		}
		
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.virtuallyghetto.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='easy_author_image-css' href='https://www.virtuallyghetto.com/wp-content/plugins/easy-author-image/css/easy-author-image.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-sample-fonts-css' href='//fonts.googleapis.com/css?family=Source+Sans+Pro%3A400%2C400i%2C600%2C700&#038;ver=2.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://www.virtuallyghetto.com/wp-includes/css/dashicons.min.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css' href='https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/css/style.css?ver=3.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css' href='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='easy_table_style-css' href='https://www.virtuallyghetto.com/wp-content/plugins/easy-table/themes/cuscosky/style.css?ver=1.8' type='text/css' media='all' />
<link rel='stylesheet' id='open-sans-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.8' type='text/css' media='all' />
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var CrayonSyntaxSettings = {"version":"_2.7.2_beta","is_admin":"0","ajaxurl":"https:\/\/www.virtuallyghetto.com\/wp-admin\/admin-ajax.php","prefix":"crayon-","setting":"crayon-setting","selected":"crayon-setting-selected","changed":"crayon-setting-changed","special":"crayon-setting-special","orig_value":"data-orig-value","debug":""};
var CrayonSyntaxStrings = {"copy":"Press %s to Copy, %s to Paste","minimize":"Click To Expand Code"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/crayon-syntax-highlighter/js/min/crayon.min.js?ver=_2.7.2_beta'></script>
<script id='st_insights_js' type='text/javascript' src='https://ws.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=7.8'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=7.8'></script>
<link rel='https://api.w.org/' href='https://www.virtuallyghetto.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.virtuallyghetto.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="https://www.virtuallyghetto.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.virtuallyghetto.com%2F2019%2F10%2Fcustomizing-the-nsx-t-login-ui.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.virtuallyghetto.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.virtuallyghetto.com%2F2019%2F10%2Fcustomizing-the-nsx-t-login-ui.html&#038;format=xml" />

<script type="text/javascript">
        (function(){
          var bsa = document.createElement('script');
              bsa.type= 'text/javascript';
              bsa.async = true;
              bsa.src='//s3.buysellads.com/ac/bsa.js';
          (document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(bsa);
        })();
        </script>

<script type="text/javascript">
	window._wp_rp_static_base_url = 'https://wprp.zemanta.com/static/';
	window._wp_rp_wp_ajax_url = "https://www.virtuallyghetto.com/wp-admin/admin-ajax.php";
	window._wp_rp_plugin_version = '3.6.4';
	window._wp_rp_post_id = '166234';
	window._wp_rp_num_rel_posts = '5';
	window._wp_rp_thumbnails = false;
	window._wp_rp_post_title = 'Customizing+the+NSX-T+Login+UI';
	window._wp_rp_post_tags = ['login.jsp', 'nsx-t', 'not+supported', 'nsx', 'backup', 'manag', 'server', 'lazi', 'applianc', 'singl', 'set', 'vmware', 'environ', 'develop', 'custom', 'ui', 'a', 'alt', 'password'];
	window._wp_rp_promoted_content = true;
</script>

<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>

<meta property="og:type" content="article" />
<meta property="og:title" content="Customizing the NSX-T Login UI" />
<meta property="og:url" content="https://www.virtuallyghetto.com/2019/10/customizing-the-nsx-t-login-ui.html" />
<meta property="og:description" content="I have been doing some automation with NSX-T 2.5 lately and for troubleshooting and validation purposes, I obviously make use of the NSX-T UI. After each new deployment I need to login to verify a …" />
<meta property="article:published_time" content="2019-10-29T18:22:14+00:00" />
<meta property="article:modified_time" content="2019-10-29T18:24:13+00:00" />
<meta property="og:site_name" content="virtuallyGhetto" />
<meta property="og:image" content="https://www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png" />
<meta property="og:image:width" content="872" />
<meta property="og:image:height" content="635" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Customizing the NSX-T Login UI" />
<meta name="twitter:card" content="summary" />

<link rel="icon" href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=240%2C240&#038;ssl=1" />
<style type="text/css" id="wp-custom-css">
				.terminal {
	border: 1px grey dashed;
	padding: 10px;
	background-color: whiteSmoke;
	color: black;
	font-family: "Lucida Console", Monaco, monospace;
	font-size: small;
}			</style>
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-166234 single-format-standard header-full-width content-sidebar genesis-breadcrumbs-visible" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://www.virtuallyghetto.com/">virtuallyGhetto</a></p></div><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary"><div class="wrap"><ul id="menu-main" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-510" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-510"><a href="https://www.virtuallyghetto.com/about" itemprop="url"><span itemprop="name">About</span></a></li>
<li id="menu-item-161462" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-161462"><a href="https://www.virtuallyghetto.com/privacy-policy" itemprop="url"><span itemprop="name">Privacy</span></a></li>
<li id="menu-item-165250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-165250"><a href="https://www.virtuallyghetto.com/vmware-cloud-on-aws" itemprop="url"><span itemprop="name">VMware Cloud on AWS</span></a></li>
<li id="menu-item-165282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-165282"><a href="https://www.virtuallyghetto.com/home-lab" itemprop="url"><span itemprop="name">Home Lab</span></a></li>
<li id="menu-item-450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-450"><a href="https://www.virtuallyghetto.com/nested-virtualization" itemprop="url"><span itemprop="name">Nested Virtualization</span></a></li>
<li id="menu-item-760" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-760"><a href="#" itemprop="url"><span itemprop="name">Automation</span></a>
<ul class="sub-menu">
<li id="menu-item-591" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-591"><a href="https://www.virtuallyghetto.com/vmware-kickstart" itemprop="url"><span itemprop="name">VMware Kickstart</span></a></li>
<li id="menu-item-593" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-593"><a href="https://www.virtuallyghetto.com/kickstart" itemprop="url"><span itemprop="name">VMware API/SDK/CLI</span></a></li>
<li id="menu-item-592" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-592"><a href="https://www.virtuallyghetto.com/vmware-vmavima" itemprop="url"><span itemprop="name">VMware vMA/VIMA</span></a></li>
<li id="menu-item-13682" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13682"><a href="https://www.virtuallyghetto.com/ovf" itemprop="url"><span itemprop="name">VMware OVF / OVFTOOL</span></a></li>
</ul>
</li>
<li id="menu-item-448" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-448"><a href="https://www.virtuallyghetto.com/apple" itemprop="url"><span itemprop="name">Apple Mac</span></a></li>
<li id="menu-item-449" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-449"><a href="https://www.virtuallyghetto.com/vcsa" itemprop="url"><span itemprop="name">VCSA</span></a></li>
<li id="menu-item-10631" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10631"><a href="https://www.virtuallyghetto.com/vsan" itemprop="url"><span itemprop="name">VSAN</span></a></li>
</ul></div></nav></div></header><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://www.virtuallyghetto.com/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Home</span></a><meta itemprop="position" content="1"></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://www.virtuallyghetto.com/category/not-supported" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Not Supported</span></a><meta itemprop="position" content="2"></span> <span aria-label="breadcrumb separator">/</span> Customizing the NSX-T Login UI</div><article class="post-166234 post type-post status-publish format-standard category-not-supported category-nsx tag-login-jsp tag-nsx-t entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Customizing the NSX-T Login UI</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2019-10-29T11:22:14-07:00">10/29/2019</time> by <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://www.virtuallyghetto.com/author/lamw" class="entry-author-link" rel="author" itemprop="url"><span class="entry-author-name" itemprop="name">William Lam</span></a></span> <span class="entry-comments-link"><a href="https://www.virtuallyghetto.com/2019/10/customizing-the-nsx-t-login-ui.html#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text"><p>I have been doing some automation with NSX-T 2.5 lately and for troubleshooting and validation purposes, I obviously make use of the NSX-T UI. After each new deployment I need to login to verify a few things. Out of pure laziness, I really would like to be able to login with just a single click for development purposes. I certainly could use password manager but it would still be a couple of clicks but I was looking something slightly quicker and that could easily work in a number of environments that I have.</p>
<p>Looking around the filesystem of the NSX Unified Appliance, I found the structure for the login UI to be fairly similiar (thanks to VMware Clarity) to that of the vCenter Server Appliance (VCSA). I found that I could apply the same techniques I had used to <a href="https://www.virtuallyghetto.com/2018/05/changes-to-vsphere-client-login-ui-customizations-in-vsphere-6-7.html" target="_blank" rel="noopener noreferrer">customize the VCSA Login UI</a> including setting up <a href="https://www.virtuallyghetto.com/2015/08/quick-tip-pre-filled-credentials-in-the-vsphere-6-0-web-client.html" target="_blank" rel="noopener noreferrer">pre-filled credentials</a> (no recommended for obvious reasons) on the NSX-T Appliance.</p>
<p><a href="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png?ssl=1" data-slb-active="1" data-slb-asset="1741857060" data-slb-internal="0" data-slb-group="166234"><img data-attachment-id="166236" data-permalink="https://www.virtuallyghetto.com/2019/10/customizing-the-nsx-t-login-ui.html/customizing-nsx-t-ui" data-orig-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png?fit=872%2C635&amp;ssl=1" data-orig-size="872,635" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="customizing-nsx-t-ui" data-image-description data-medium-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png?fit=300%2C218&amp;ssl=1" data-large-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png?fit=702%2C511&amp;ssl=1" class="alignnone wp-image-166236 jetpack-lazy-image" src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png?resize=650%2C473&#038;ssl=1" alt width="650" height="473" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png?w=872&amp;ssl=1 872w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png?resize=300%2C218&amp;ssl=1 300w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png?resize=768%2C559&amp;ssl=1 768w" data-lazy-sizes="(max-width: 650px) 100vw, 650px" data-lazy-src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png?resize=650%2C473&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="166236" data-permalink="https://www.virtuallyghetto.com/2019/10/customizing-the-nsx-t-login-ui.html/customizing-nsx-t-ui" data-orig-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png?fit=872%2C635&amp;ssl=1" data-orig-size="872,635" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="customizing-nsx-t-ui" data-image-description="" data-medium-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png?fit=300%2C218&amp;ssl=1" data-large-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png?fit=702%2C511&amp;ssl=1" class="alignnone wp-image-166236" src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png?resize=650%2C473&#038;ssl=1" alt="" width="650" height="473" srcset="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png?w=872&amp;ssl=1 872w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png?resize=300%2C218&amp;ssl=1 300w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/10/customizing-nsx-t-ui.png?resize=768%2C559&amp;ssl=1 768w" sizes="(max-width: 650px) 100vw, 650px" data-recalc-dims="1" /></noscript></a><br />
<span style="color: #ff0000;"><strong>Disclaimer:</strong></span> This is not officially supported by VMware, use at your own risk. Please make sure to perform a backup of all original files prior to editing in case you need to restore back the system defaults.</p>
<p><span id="more-166234"></span></p>
<p>If you wish to hardcode the username and/or password, you will need to login as root and modify <strong>/opt/vmware/proxy-tomcat/webapps/ROOT/login.jsp</strong> and below is an example:</p>
<div id="crayon-5db89181b564f498225010" class="crayon-syntax crayon-theme-tomorrow-night crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-mixed-highlight" title="Contains Mixed Languages"></span><div class="crayon-button crayon-nums-button" title="Toggle Line Numbers"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Toggle Plain Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Open Code In New Window"><div class="crayon-button-icon"></div></div><span class="crayon-language">CSS</span></div></div>
<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
&lt;input class="username" type="text" id="username" name="j_username" autocomplete="off"
     placeholder="&lt;%=resource.getString("username.placeholder.label")%&gt;" value="admin"&gt;
&lt;input class="password" type="password" id="password" name="j_password" autocomplete="off"
     placeholder="&lt;%=resource.getString("password.placeholder.label")%&gt;" value="VMware1!VMware1!"&gt;</textarea></div>
<div class="crayon-main" style="">
<table class="crayon-table">
<tr class="crayon-row">
<td class="crayon-nums " data-settings="show">
<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5db89181b564f498225010-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5db89181b564f498225010-2">2</div><div class="crayon-num" data-line="crayon-5db89181b564f498225010-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5db89181b564f498225010-4">4</div></div>
</td>
<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5db89181b564f498225010-1"><span class="crayon-ta">&lt;input </span><span class="crayon-e ">class</span><span class="crayon-k ">="username" type="text" id="username" name="j_username" autocomplete="off"</span></div><div class="crayon-line crayon-striped-line" id="crayon-5db89181b564f498225010-2"><span class="crayon-k ">&nbsp;&nbsp;&nbsp;&nbsp; placeholder="</span><span class="crayon-ta">&lt;%=</span><span class="crayon-v">resource</span><span class="crayon-sy">.</span><span class="crayon-e">getString</span><span class="crayon-sy">(</span><span class="crayon-s">"username.placeholder.label"</span><span class="crayon-sy">)</span><span class="crayon-ta">%&gt;</span><span class="crayon-s">" value="</span><span class="crayon-k ">admin"&gt;</span></div><div class="crayon-line" id="crayon-5db89181b564f498225010-3"><span class="crayon-k ">&lt;input class="password" type="password" id="password" name="j_password" autocomplete="off"</span></div><div class="crayon-line crayon-striped-line" id="crayon-5db89181b564f498225010-4"><span class="crayon-k ">&nbsp;&nbsp;&nbsp;&nbsp; placeholder="</span><span class="crayon-ta">&lt;%=</span><span class="crayon-v">resource</span><span class="crayon-sy">.</span><span class="crayon-e">getString</span><span class="crayon-sy">(</span><span class="crayon-s">"password.placeholder.label"</span><span class="crayon-sy">)</span><span class="crayon-ta">%&gt;</span><span class="crayon-s">" value="</span><span class="crayon-i ">VMware1</span><span class="crayon-sy">!</span><span class="crayon-i ">VMware1</span><span class="crayon-sy">!</span><span class="crayon-i ">"&gt;</span></div></div></td>
</tr>
</table>
</div>
</div>

<p>If want your changes to persist a reboot, you will need to extract /<strong>opt/vmware/proxy-tomcat/webapps/ROOT.war</strong> and make the changes and repackage the WAR file.</p>
<p>While I was at this, I figure why not update the boring background as well? 🙂 This is certainly a be a bit more involved, especially as the CSS file contents are minify to a single line which you will need to un-minify. If you wish to play around with the login UI background, you can take a look at <strong>/opt/vmware/proxy-tomcat/webapps/ROOT/reverse-proxy/styles/clarity-ui.min.css</strong> and to persist the configurations, you will also need to incorporate the changes into the ROOT.war file.</p>
<div class="wp_rp_wrap  wp_rp_vertical_m" id="wp_rp_first"><div class="wp_rp_content"><h3 class="related_post_title">More from my site</h3><ul class="related_post wp_rp"><li data-position="0" data-poid="in-164021" data-post-type="none"><a href="https://www.virtuallyghetto.com/2019/02/which-nsx-t-policy-apis-are-used-in-the-nsx-t-ui-in-vmc.html" class="wp_rp_title">Which NSX-T Policy APIs are used in the NSX-T UI in VMC?</a></li><li data-position="1" data-poid="in-165102" data-post-type="none"><a href="https://www.virtuallyghetto.com/2019/05/nsx-t-policy-api-explorer-docs-and-sample-updates-for-vmc.html" class="wp_rp_title">NSX-T Policy API Explorer, Docs and Sample Updates for VMC</a></li><li data-position="2" data-poid="in-160391" data-post-type="none"><a href="https://www.virtuallyghetto.com/2018/03/esxi-host-with-network-redundancy-using-nsx-t-and-only-2-pnics.html" class="wp_rp_title">ESXi host with network redundancy using NSX-T and only 2 pNICs?</a></li><li data-position="3" data-poid="in-159935" data-post-type="none"><a href="https://www.virtuallyghetto.com/2018/01/quick-tip-nsx-t-2-1-upgrade-gotcha-use-nsx-manger-ip-address-vs-hostname.html" class="wp_rp_title">Quick Tip &#8211; NSX-T 2.1 upgrade gotcha, use NSX Manager IP Address vs Hostname</a></li><li data-position="4" data-poid="in-159315" data-post-type="none"><a href="https://www.virtuallyghetto.com/2017/10/nsx-t-powercli-community-module.html" class="wp_rp_title">NSX-T PowerCLI community module</a></li></ul></div></div>
<div class="ssba-modern-2 ssba ssbp-wrap left ssbp--theme-1"><div style="text-align:left"><span class="ssba-share-text">Share this...</span><br /><ul class="ssbp-list"><li class="ssbp-li--twitter"><a data-site="" class="ssba_twitter_share ssbp-twitter ssbp-btn" href="https://twitter.com/share?url=https://www.virtuallyghetto.com/2019/10/customizing-the-nsx-t-login-ui.html&amp;text=Customizing%20the%20NSX-T%20Login%20UI%20" target=&quot;_blank&quot;><div title="Twitter" class="ssbp-text">Twitter</div></a></li><li class="ssbp-li--facebook"><a data-site="" class="ssba_facebook_share ssbp-facebook ssbp-btn" href="https://www.facebook.com/sharer.php?u=https://www.virtuallyghetto.com/2019/10/customizing-the-nsx-t-login-ui.html" target="_blank"><div title="Facebook" class="ssbp-text">Facebook</div></a></li><li class="ssbp-li--linkedin"><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link ssbp-linkedin ssbp-btn" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.virtuallyghetto.com/2019/10/customizing-the-nsx-t-login-ui.html" target=&quot;_blank&quot;><div title="Linkedin" class="ssbp-text">Linkedin</div></a></li><li class="ssbp-li--reddit"><a data-site="reddit" class="ssba_reddit_share ssbp-reddit ssbp-btn" href="https://reddit.com/submit?url=https://www.virtuallyghetto.com/2019/10/customizing-the-nsx-t-login-ui.html&amp;title=Customizing the NSX-T Login UI" target=&quot;_blank&quot;><div title="Reddit" class="ssbp-text">Reddit</div></a></li><li class="ssbp-li--pinterest"><a data-site='pinterest' class='ssba_pinterest_share ssbp-pinterest ssbp-btn' href='javascript:void((function()%7Bvar%20e=document.createElement(&apos;script&apos;);e.setAttribute(&apos;type&apos;,&apos;text/javascript&apos;);e.setAttribute(&apos;charset&apos;,&apos;UTF-8&apos;);e.setAttribute(&apos;src&apos;,&apos;//assets.pinterest.com/js/pinmarklet.js?r=&apos;+Math.random()*99999999);document.body.appendChild(e)%7D)());'><div title="Pinterest" class="ssbp-text">Pinterest</div></a></li></ul></div></div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://www.virtuallyghetto.com/category/not-supported" rel="category tag">Not Supported</a>, <a href="https://www.virtuallyghetto.com/category/nsx" rel="category tag">NSX</a></span> <span class="entry-tags">Tagged With: <a href="https://www.virtuallyghetto.com/tag/login-jsp" rel="tag">login.jsp</a>, <a href="https://www.virtuallyghetto.com/tag/nsx-t" rel="tag">NSX-T</a></span></p></footer></article><h2 class="screen-reader-text">Reader Interactions</h2>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Thanks for the comment! <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/10/customizing-the-nsx-t-login-ui.html#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=67295360&#038;postid=166234&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=retro&#038;greeting=Thanks+for+the+comment%21&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=transparent&#038;lang=en_US&#038;jetpack_version=7.8&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=9b6047892233f0b9c413176ae56ed3980aa95bc8#parent=https%3A%2F%2Fwww.virtuallyghetto.com%2F2019%2F10%2Fcustomizing-the-nsx-t-login-ui.html" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = true;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="search-7" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://www.virtuallyghetto.com/" role="search" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction"><label class="search-form-label screen-reader-text" for="searchform-1">Search this website</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website" itemprop="query-input"><input class="search-form-submit" type="submit" value="Search"><meta content="https://www.virtuallyghetto.com/?s={s}" itemprop="target"></form></div></section>
<section id="user-profile-9" class="widget user-profile"><div class="widget-wrap"><h3 class="widgettitle widget-title">Author</h3>
<p><span class="alignleft"><img class="avatar avatar-125 photo jetpack-lazy-image" width="64" height="64" src="https://www.virtuallyghetto.com/wp-content/uploads/2017/01/292c324.jpg" data-lazy-src="https://www.virtuallyghetto.com/wp-content/uploads/2017/01/292c324.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="avatar avatar-125 photo" width="64" height="64" src="https://www.virtuallyghetto.com/wp-content/uploads/2017/01/292c324.jpg"/></noscript></span>William Lam is a Staff Solution Architect working in the VMware Cloud on AWS team within the Cloud Platform Business Unit (CPBU) at VMware. He focuses on Automation, Integration and Operation of the VMware Software Defined Datacenter (SDDC).</p>
</div></section>
<section id="simple-social-icons-4" class="widget simple-social-icons"><div class="widget-wrap"><ul class="aligncenter"><li class="ssi-github"><a href="https://github.com/lamw" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-github" aria-labelledby="social-github-4"><title id="social-github-4">GitHub</title><use xlink:href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-github"></use></svg></a></li><li class="ssi-gplus"><a href="https://plus.google.com/114142893306148938477" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-gplus" aria-labelledby="social-gplus-4"><title id="social-gplus-4">Google+</title><use xlink:href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-gplus"></use></svg></a></li><li class="ssi-linkedin"><a href="https://www.linkedin.com/in/lamwilliam/" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-linkedin" aria-labelledby="social-linkedin-4"><title id="social-linkedin-4">LinkedIn</title><use xlink:href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-linkedin"></use></svg></a></li><li class="ssi-rss"><a href="https://www.virtuallyghetto.com/rss" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-rss" aria-labelledby="social-rss-4"><title id="social-rss-4">RSS</title><use xlink:href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-rss"></use></svg></a></li><li class="ssi-twitter"><a href="https://twitter.com/lamw" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-twitter" aria-labelledby="social-twitter-4"><title id="social-twitter-4">Twitter</title><use xlink:href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li></ul></div></section>
<section id="bsa-6" class="widget widget_bsa"><div class="widget-wrap"><h3 class="widgettitle widget-title">Sponsors</h3>

<div id="bsap_1282588" class="bsarocks bsap_6d274f0434e88e8f84574d74902bc1c4"></div>

</div></section>
<section id="eu_cookie_law_widget-2" class="widget widget_eu_cookie_law_widget"><div class="widget-wrap"><div class="hide-on-button negative" data-hide-timeout="30" data-consent-expiration="180" id="eu-cookie-law">
<form method="post">
<input type="submit" value="Close and accept" class="accept" />
</form>
Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
<a href="https://www.virtuallyghetto.com/privacy-policy">
Cookie Policy	</a>
</div>
</div></section>
</aside></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"></div></footer></div> <div style="display:none">
<div class="grofile-hash-map-b9d29da4e111863744d8421dc0801219">
</div>
</div>
<style type="text/css" media="screen"> #simple-social-icons-4 ul li a, #simple-social-icons-4 ul li a:hover, #simple-social-icons-4 ul li a:focus { background-color: #000000 !important; border-radius: 6px; color: #ffffff !important; border: 0px #ffffff solid !important; font-size: 18px; padding: 9px; }  #simple-social-icons-4 ul li a:hover, #simple-social-icons-4 ul li a:focus { background-color: #830101 !important; border-color: #ffffff !important; color: #ffffff !important; }  #simple-social-icons-4 ul li a:focus { outline: 1px dotted #830101 !important; }</style><link rel='stylesheet' id='simple-share-buttons-adder-ssba-css' href='https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=5.2.4' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
.ssba img
								{border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								.ssba-classic-2 .ssbp-text {
									display: none!important;
								}
					.ssbp-list li a {height: 32px!important; width: 32px!important; 
					}
					.ssbp-list li a:hover {
					}
						
					.ssbp-list li a::before {line-height: 32px!important;; font-size: 24px;}
					.ssbp-list li a:hover::before {}
					.ssbp-list li {
					margin-left: 12px!important;
					}
					
					.ssba-share-text {
					font-size: 14px;  font-weight: normal; font-family: inherit;
						}

			   #ssba-bar-2 .ssbp-bar-list {
					max-width: 48px!important;;
			   }
			   #ssba-bar-2 .ssbp-bar-list li a {height: 48px!important; width: 48px!important; 
				}
				#ssba-bar-2 .ssbp-bar-list li a:hover {
				}
					
				#ssba-bar-2 .ssbp-bar-list li a::before {line-height: 48px!important;; font-size: 18px;}
				#ssba-bar-2 .ssbp-bar-list li a:hover::before {}
				#ssba-bar-2 .ssbp-bar-list li {
				margin: 0px 0!important;
				}@media only screen and ( max-width: 750px ) {
				#ssba-bar-2 {
				display: block;
				}
			}
@font-face {
				font-family: 'ssbp';
				src:url('https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?xj3ol1');
				src:url('https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?#iefixxj3ol1') format('embedded-opentype'),
					url('https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.woff?xj3ol1') format('woff'),
					url('https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.ttf?xj3ol1') format('truetype'),
					url('https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.svg?xj3ol1#ssbp') format('svg');
				font-weight: normal;
				font-style: normal;

				/* Better Font Rendering =========== */
				-webkit-font-smoothing: antialiased;
				-moz-osx-font-smoothing: grayscale;
			}
</style>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.0.0'></script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://www.virtuallyghetto.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.virtuallyghetto.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.26.0-0"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.virtuallyghetto.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.virtuallyghetto.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-includes/js/dist/dom-ready.min.js?ver=2.2.0'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20190901'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201944'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.js?ver=5.2.4'></script>
<script type='text/javascript'>
Main.boot( [] );
</script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Octaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.2.4'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-includes/js/comment-reply.min.js?ver=5.2.4'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=3.1.2'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=3.1.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var genesis_responsive_menu = {"mainMenu":"Menu","menuIconClass":"dashicons-before dashicons-menu","subMenu":"Submenu","subMenuIconClass":"dashicons-before dashicons-arrow-down-alt2","menuClasses":{"combine":[".nav-primary"],"others":[]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/themes/genesis-sample/js/responsive-menus.min.js?ver=2.6.0'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/themes/genesis-sample/js/genesis-sample.js?ver=2.6.0'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js?ver=20180522'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/lazy-images/js/lazy-images.min.js?ver=7.8'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=7.8'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-includes/js/wp-embed.min.js?ver=5.2.4'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.virtuallyghetto.com\/wp-admin\/admin-ajax.php","nonce":"3d7aa14971","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.virtuallyghetto.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.virtuallyghetto.com%2F2019%2F10%2Fcustomizing-the-nsx-t-login-ui.html","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20190102'></script>
<script async="async" type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.2'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/client/js/prod/lib.core.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/client/js/prod/lib.view.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/themes/baseline/js/prod/client.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/themes/default/js/prod/client.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/template-tags/item/js/prod/tag.item.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/template-tags/ui/js/prod/tag.ui.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/content-handlers/image/js/prod/handler.image.js?ver=2.7.1'></script>
<script type="text/javascript" id="slb_footer">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB && SLB.has_child('View.init') ) { SLB.View.init({"ui_autofit":true,"ui_animate":true,"slideshow_autostart":true,"slideshow_duration":"6","group_loop":true,"ui_overlay_opacity":"0.8","ui_title_default":false,"theme_default":"slb_default","ui_labels":{"loading":"Loading","close":"Close","nav_next":"Next","nav_prev":"Previous","slideshow_start":"Start slideshow","slideshow_stop":"Stop slideshow","group_status":"Item %current% of %total%"}}); }
if ( !!window.SLB && SLB.has_child('View.assets') ) { {$.extend(SLB.View.assets, {"1741857060":{"id":166236,"type":"image","source":"https:\/\/www.virtuallyghetto.com\/wp-content\/uploads\/2019\/10\/customizing-nsx-t-ui.png","internal":true,"sizes":{"thumbnail":{"file":"customizing-nsx-t-ui-150x150.png","width":150,"height":150,"mime-type":"image\/png"},"medium":{"file":"customizing-nsx-t-ui-300x218.png","width":300,"height":218,"mime-type":"image\/png"},"medium_large":{"file":"customizing-nsx-t-ui-768x559.png","width":768,"height":559,"mime-type":"image\/png"},"wp_rp_thumbnail":{"file":"customizing-nsx-t-ui-150x150.png","width":150,"height":150,"mime-type":"image\/png"},"original":{"file":"2019\/10\/customizing-nsx-t-ui.png","width":872,"height":635}},"image_meta":{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"0","keywords":[]},"description":"","title":"customizing-nsx-t-ui","caption":""}});} }
/* THM */
if ( !!window.SLB && SLB.has_child('View.extend_theme') ) { SLB.View.extend_theme('slb_baseline',{"name":"Baseline","parent":"","styles":[{"handle":"base","uri":"https:\/\/www.virtuallyghetto.com\/wp-content\/plugins\/simple-lightbox\/themes\/baseline\/css\/style.css","deps":[]}],"layout_raw":"<div class=\"slb_container\"><div class=\"slb_content\">{{item.content}}<div class=\"slb_nav\"><span class=\"slb_prev\">{{ui.nav_prev}}<\/span><span class=\"slb_next\">{{ui.nav_next}}<\/span><\/div><div class=\"slb_controls\"><span class=\"slb_close\">{{ui.close}}<\/span><span class=\"slb_slideshow\">{{ui.slideshow_control}}<\/span><\/div><div class=\"slb_loading\">{{ui.loading}}<\/div><\/div><div class=\"slb_details\"><div class=\"inner\"><div class=\"slb_data\"><div class=\"slb_data_content\"><span class=\"slb_data_title\">{{item.title}}<\/span><span class=\"slb_group_status\">{{ui.group_status}}<\/span><div class=\"slb_data_desc\">{{item.description}}<\/div><\/div><\/div><div class=\"slb_nav\"><span class=\"slb_prev\">{{ui.nav_prev}}<\/span><span class=\"slb_next\">{{ui.nav_next}}<\/span><\/div><\/div><\/div><\/div>"}); }if ( !!window.SLB && SLB.has_child('View.extend_theme') ) { SLB.View.extend_theme('slb_default',{"name":"Default (Light)","parent":"slb_baseline","styles":[{"handle":"base","uri":"https:\/\/www.virtuallyghetto.com\/wp-content\/plugins\/simple-lightbox\/themes\/default\/css\/style.css","deps":[]}]}); }})})(jQuery);}/* ]]> */</script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=67295360&postid=166234&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=retro&greeting=Thanks+for+the+comment%21&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=7.8&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=9b6047892233f0b9c413176ae56ed3980aa95bc8#parent=https%3A%2F%2Fwww.virtuallyghetto.com%2F2019%2F10%2Fcustomizing-the-nsx-t-login-ui.html" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=67295360&postid=166234&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=retro&greeting=Thanks+for+the+comment%21&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=7.8&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=9b6047892233f0b9c413176ae56ed3980aa95bc8#parent=https%3A%2F%2Fwww.virtuallyghetto.com%2F2019%2F10%2Fcustomizing-the-nsx-t-login-ui.html";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script type='text/javascript' src='https://stats.wp.com/e-201944.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.8',blog:'67295360',post:'166234',tz:'-7',srv:'www.virtuallyghetto.com'} ]);
	_stq.push([ 'clickTrackerInit', '67295360', '166234' ]);
</script>
</body></html>
