<!DOCTYPE html>
<!--[if IE 8]>
<html class="ie8" lang="en-US">
<![endif]-->
<!--[if gt IE 8]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta property="twitter:account_id" content="16227829" />
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>Deployment models for vSphere Content Library | virtuallyGhetto</title>
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.virtuallyghetto.com/xmlrpc.php" />
<link href="https://fonts.googleapis.com/css?family=Roboto+Slab:300,400,700,100" rel='stylesheet' type='text/css'>
<script>(function(d, s, id){
				 var js, fjs = d.getElementsByTagName(s)[0];
				 if (d.getElementById(id)) {return;}
				 js = d.createElement(s); js.id = id;
				 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
				 fjs.parentNode.insertBefore(js, fjs);
			   }(document, 'script', 'facebook-jssdk'));</script><link rel='dns-prefetch' href='//www.virtuallyghetto.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//w.sharethis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="virtuallyGhetto &raquo; Feed" href="https://www.virtuallyghetto.com/feed" />
<link rel="alternate" type="application/rss+xml" title="virtuallyGhetto &raquo; Comments Feed" href="https://www.virtuallyghetto.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="virtuallyGhetto &raquo; Deployment models for vSphere Content Library Comments Feed" href="https://www.virtuallyghetto.com/2017/12/deployment-models-for-vsphere-content-library.html/feed" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.virtuallyghetto.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='crayon-css' href="https://www.virtuallyghetto.com/wp-content/plugins/crayon-syntax-highlighter/css/min/crayon.min.css?ver=_2.7.2_beta" type='text/css' media='all' />
<link rel='stylesheet' id='easy_author_image-css' href="https://www.virtuallyghetto.com/wp-content/plugins/easy-author-image/css/easy-author-image.css?ver=4.9.1" type='text/css' media='all' />
<link rel='stylesheet' id='m1-style-css' href="https://www.virtuallyghetto.com/wp-content/themes/m1/style.css?ver=4.9.1" type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css' href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/css/style.css?ver=2.0.1" type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css' href="https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.6.0" type='text/css' media='all' />
<link rel='stylesheet' id='easy_table_style-css' href="https://www.virtuallyghetto.com/wp-content/plugins/easy-table/themes/cuscosky/style.css?ver=1.6" type='text/css' media='all' />
<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;background:#000;margin:5px}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(http://www.virtuallyghetto.com/wp-content/plugins/rocket-lazy-load/assets/img/play.png) no-repeat;cursor:pointer}
</style>
<link rel='stylesheet' id='jetpack_css-css' href="https://www.virtuallyghetto.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.5.1" type='text/css' media='all' />
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-includes/js/jquery/jquery.js?ver=1.12.4"></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var CrayonSyntaxSettings = {"version":"_2.7.2_beta","is_admin":"0","ajaxurl":"http:\/\/www.virtuallyghetto.com\/wp-admin\/admin-ajax.php","prefix":"crayon-","setting":"crayon-setting","selected":"crayon-setting-selected","changed":"crayon-setting-changed","special":"crayon-setting-special","orig_value":"data-orig-value","debug":""};
var CrayonSyntaxStrings = {"copy":"Press %s to Copy, %s to Paste","minimize":"Click To Expand Code"};
/* ]]> */
</script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/plugins/crayon-syntax-highlighter/js/min/crayon.min.js?ver=_2.7.2_beta"></script>
<script id='st_insights_js' type='text/javascript' src="https://ws.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare"></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/themes/m1/js/modernizr.js?ver=4.9.1"></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/themes/m1/js/off-canvas-nav-simple.js?ver=4.9.1"></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/themes/m1/js/superfish.js?ver=4.9.1"></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21"></script>
<script type="text/javascript">
	!function(){var analytics=window.analytics=window.analytics||[];if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["trackSubmit","trackClick","trackLink","trackForm","pageview","identify","group","track","ready","alias","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="3.0.0";
		window.analytics.load("87b6nylkx2");
	window.analytics.page();
	  }}();
</script>
<link rel='https://api.w.org/' href="https://www.virtuallyghetto.com/wp-json/" />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.virtuallyghetto.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.virtuallyghetto.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='How to audit vSphere API usage?' href="https://www.virtuallyghetto.com/2017/11/how-to-audit-vsphere-api-usage.html" />
<meta name="generator" content="WordPress 4.9.1" />
<link rel="canonical" href="https://www.virtuallyghetto.com/2017/12/deployment-models-for-vsphere-content-library.html" />
<link rel='shortlink' href='https://wp.me/p4ymB2-FuW' />
<link rel="alternate" type="application/json+oembed" href="https://www.virtuallyghetto.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.virtuallyghetto.com%2F2017%2F12%2Fdeployment-models-for-vsphere-content-library.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.virtuallyghetto.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.virtuallyghetto.com%2F2017%2F12%2Fdeployment-models-for-vsphere-content-library.html&#038;format=xml" />

<script type="text/javascript">
        (function(){
          var bsa = document.createElement('script');
              bsa.type= 'text/javascript';
              bsa.async = true;
              bsa.src='//s3.buysellads.com/ac/bsa.js';
          (document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(bsa);
        })();
        </script>

<script type="text/javascript">
	window._wp_rp_static_base_url = 'https://wprp.zemanta.com/static/';
	window._wp_rp_wp_ajax_url = "http://www.virtuallyghetto.com/wp-admin/admin-ajax.php";
	window._wp_rp_plugin_version = '3.6.4';
	window._wp_rp_post_id = '159522';
	window._wp_rp_num_rel_posts = '6';
	window._wp_rp_thumbnails = false;
	window._wp_rp_post_title = 'Deployment+models+for+vSphere+Content+Library';
	window._wp_rp_post_tags = ['vsphere+6.0', 'vsphere+6.5', 'content+library', 'vsphere+6.0', 'vsphere+6.5', 'vsphere', 'server', 'singl', 'optim', 'vsphere', 'wan', 'case', 'librari', 'content', '2', 'tabl', 'manag', 'model', 'storag', 'remot', 'custom'];
	window._wp_rp_promoted_content = true;
</script>
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<script type="text/javascript">
    jQuery(document).ready(function($) {
                $('nav ul.menu').superfish({
                        hoverClass:  'sfHover',
                        disableHI:   true,
                        delay:       0,                               // no delay on mouseout
                        animation:   {opacity:'show',height:'show'},  // fade-in and slide-down animation
                        speed:       'fast',                          // faster animation speed
                        cssArrows:   true                             // arrows
                });
        });
  </script>
<style type="text/css" media="screen"> .simple-social-icons ul li a, .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus { background-color: #999999 !important; border-radius: 4px; color: #ffffff !important; border: 0px #ffffff solid !important; font-size: 18px; padding: 9px; }  .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus { background-color: #a02724 !important; border-color: #ffffff !important; color: #ffffff !important; }  .simple-social-icons ul li a:focus { outline: 1px dotted #a02724 !important; }</style>

<meta property="og:type" content="article" />
<meta property="og:title" content="Deployment models for vSphere Content Library" />
<meta property="og:url" content="http://www.virtuallyghetto.com/2017/12/deployment-models-for-vsphere-content-library.html" />
<meta property="og:description" content="When talking to customers about vSphere Content Library deployments, one question I normally get is how best deploy Content Library for optimal workload deployment, especially in scenarios where re…" />
<meta property="article:published_time" content="2017-12-01T15:24:24+00:00" />
<meta property="article:modified_time" content="2017-12-01T15:24:24+00:00" />
<meta property="og:site_name" content="virtuallyGhetto" />
<meta property="og:image" content="https://www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-1.png" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="548" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Deployment models for vSphere Content Library" />
<meta name="twitter:card" content="summary" />
<link rel="icon" href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=240%2C240" />
<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://www.virtuallyghetto.com/?custom-css=87480a5188" />
<style>
                .top-menu-container, .top-menu ul ul, .navigation-main ul ul, .navigation-main li.sfHover:hover { background-color:  #ffffff; }                        .top-menu a, .top-menu ul ul a, .navigation-main a, .navigation-main ul ul a, .navigation-main li.sfHover a, .m1-social-icons a { color: #0a0a0a; }                        </style>
</head>
<body class="post-template-default single single-post postid-159522 single-format-standard">
<div id="page" class="hfeed site">
<header id="masthead" class="site-header" role="banner">
<section class="top-menu-container">
<div class="top-menu-inside">
<div class="m1-social-icons">
</div>
</div>
</section>
<section class="site-branding">
<a class="nav-btn" id="nav-open-btn">Menu</a>
<div class="site-title-wrap">
<hgroup>
<h1 class="site-title"><a href="https://www.virtuallyghetto.com/" title="virtuallyGhetto" rel="home">virtuallyGhetto</a></h1>
<p class="site-description"></p>
</hgroup>
</div>
<div id="header-widget-area">
</div>
<nav id="site-navigation" class="navigation-main" role="navigation">
<a class="close-btn" id="nav-close-btn">Close Menu</a>
<div class="screen-reader-text skip-link"><a href="#content" title="Skip to content">Skip to content</a></div>
<div class="menu-main-container"><ul id="menu-main" class="menu"><li id="menu-item-510" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-510"><a href="https://www.virtuallyghetto.com/about">About</a></li>
<li id="menu-item-760" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-760"><a href="#">Automation</a>
<ul class="sub-menu">
<li id="menu-item-591" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-591"><a href="https://www.virtuallyghetto.com/vmware-kickstart">VMware Kickstart</a></li>
<li id="menu-item-593" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-593"><a href="https://www.virtuallyghetto.com/kickstart">VMware API/SDK/CLI</a></li>
<li id="menu-item-592" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-592"><a href="https://www.virtuallyghetto.com/vmware-vmavima">VMware vMA/VIMA</a></li>
<li id="menu-item-13682" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13682"><a href="https://www.virtuallyghetto.com/ovf">VMware OVF / OVFTOOL</a></li>
</ul>
</li>
<li id="menu-item-448" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-448"><a href="https://www.virtuallyghetto.com/apple">Apple Mac Mini/Pro</a></li>
<li id="menu-item-450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-450"><a href="https://www.virtuallyghetto.com/nested-virtualization">Nested Virtualization</a></li>
<li id="menu-item-449" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-449"><a href="https://www.virtuallyghetto.com/vcsa">VCSA</a></li>
<li id="menu-item-10631" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10631"><a href="https://www.virtuallyghetto.com/vsan">VSAN</a></li>
</ul></div> </nav>
</section>
</header>
<div id="main" class="site-main">
<header class="entry-header">
<h1 class="page-title">Deployment models for vSphere Content Library</h1>
</header>
<div id="primary" class="content-area">
<div id="content" class="site-content" role="main">
<article id="post-159522" class="post-159522 post type-post status-publish format-standard hentry category-vsphere category-vsphere-6-0 category-vsphere-6-5 tag-content-library tag-vsphere-6-0 tag-vsphere-6-5">
<div class="entry-meta">
Posted on <a href="https://www.virtuallyghetto.com/2017/12/deployment-models-for-vsphere-content-library.html" title="7:24 am" rel="bookmark"><time class="entry-date" datetime="2017-12-01T07:24:24+00:00">12/01/2017</time></a><span class="byline"> by <span class="author vcard"><a class="url fn n" href="https://www.virtuallyghetto.com/author/lamw" title="View all posts by William Lam" rel="author">William Lam</a></span></span> </div>
<div class="entry-content">
<p>When talking to customers about <a href="https://github.com/lamw/usb-to-sddc/blob/master/DeployVM-Scripts/rc.local#L105">vSphere Content Library</a> deployments, one question I normally get is how best deploy Content Library for optimal workload deployment, especially in scenarios where remote or branch offices are involved? There are two main deployment models for vSphere Content Library as the title has alluded to. The main difference between the two is whether you have a single vCenter Server or if you have multiple vCenter Servers, with each managing its own vSphere infrastructure?</p>
<p>Lets refer to the single vCenter Server case as Scenario 1 and the multi-vCenter Server case as Scenario 2 and below are the two scenarios outlined with additional details.</p>
<p><strong>Scenario 1 (Single vCenter Server):</strong></p>
<p>In this scenario, which is a fairly common deployment for many smaller to mid-size organizations, where you only have a single or very few vCenter Server(s). They are used to manage several remote locations which only consists of ESXi hosts running at each of the locations and storage local to the site is available. In addition, there are several expected behaviors of the content itself which I have formulated into the following table below:</p>
<div class="table-responsive"><table style="width:100%; " class="easy-table easy-table-cuscosky fixed-table">
<thead>
<tr><th>Content Management</th>
<th> Content Distribution</th>
<th> Content Deployment</th>
</tr>
</thead>
<tbody>
<tr><td>Centrally Managed</td>
<td> Sync across the WAN</td>
<td> Workloads stored and deployed locally</td>
</tr>
</tbody></table></div>
<p>For this type of an environment, you would first setup a published library which stores all the content that you wish to distribute across your remote sites. Next, you would create subscriber library(s) consuming the published library, but instead of storing the replicated content locally, it is actually stored at each of the remote locations and their respective vSphere Datastore(s). This ensures that content is synchronized from our published library out to each of the remote locations, but when content is requested for deployment, the traffic is local to the site rather than going across the WAN.</p>
<p><a href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-0.png?ssl=1" data-slb-active="1" data-slb-asset="1433466157" data-slb-internal="0" data-slb-group="159522"><img data-attachment-id="159527" data-permalink="http://www.virtuallyghetto.com/2017/12/deployment-models-for-vsphere-content-library.html/vsphere-contetn-library-deployment-models-0#main" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-0.png?fit=992%2C579" data-orig-size="992,579" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="vsphere-contetn-library-deployment-models-0" data-image-description="" data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-0.png?fit=300%2C175" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-0.png?fit=770%2C449" class="alignnone wp-image-159527" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-0.png?resize=770%2C449&#038;ssl=1" alt="" data-recalc-dims="1" /><noscript><img data-attachment-id="159527" data-permalink="http://www.virtuallyghetto.com/2017/12/deployment-models-for-vsphere-content-library.html/vsphere-contetn-library-deployment-models-0#main" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-0.png?fit=992%2C579" data-orig-size="992,579" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="vsphere-contetn-library-deployment-models-0" data-image-description="" data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-0.png?fit=300%2C175" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-0.png?fit=770%2C449" class="alignnone wp-image-159527" src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-0.png?resize=770%2C449&#038;ssl=1" alt="" data-recalc-dims="1" /></noscript></a><br />
In the above scenario, since there is only a single vCenter Server, if it ever becomes unavailable then provisioning and management to the remote location will also be unavailable. This is the expected behavior regardless if Content Library is configured.</p>
<p><strong>Scenario 2 (Multi-vCenter Server):</strong></p>
<p>In this scenario, each location has its own vCenter Server and set of local resources (ESXi hosts, vSphere Datastores, etc) that it manages. The expected behaviors of content management, distribution and deployment is also simliar to our first scenario which is highlighted below:</p>
<div class="table-responsive"><table style="width:100%; " class="easy-table easy-table-cuscosky fixed-table">
<thead>
<tr><th>Content Management</th>
<th> Content Distribution</th>
<th> Content Deployment</th>
</tr>
</thead>
<tbody>
<tr><td>Centrally Managed</td>
<td> Sync across the WAN</td>
<td> Workloads stored and deployed locally</td>
</tr>
</tbody></table></div>
<p>For this type of an environment, you would first setup a published library which stores all the content that you wish to distribute across your remote sites. Next, you would create a subscriber library at each of the remote locations where content will be replicated to the locally within the site. Simliar to our first scenario, content will also be synchronized from our published library out to each of the remote locations and when content is requested for deployment, the traffic is localized to the site rather than going across the WAN.</p>
<p><a href="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-1.png?ssl=1" data-slb-active="1" data-slb-asset="1649777321" data-slb-internal="0" data-slb-group="159522"><img data-attachment-id="159528" data-permalink="http://www.virtuallyghetto.com/2017/12/deployment-models-for-vsphere-content-library.html/vsphere-contetn-library-deployment-models-1#main" data-orig-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-1.png?fit=1022%2C700" data-orig-size="1022,700" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="vsphere-contetn-library-deployment-models-1" data-image-description="" data-medium-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-1.png?fit=300%2C205" data-large-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-1.png?fit=770%2C527" class="alignnone wp-image-159528" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-1.png?resize=770%2C527&#038;ssl=1" alt="" data-recalc-dims="1" /><noscript><img data-attachment-id="159528" data-permalink="http://www.virtuallyghetto.com/2017/12/deployment-models-for-vsphere-content-library.html/vsphere-contetn-library-deployment-models-1#main" data-orig-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-1.png?fit=1022%2C700" data-orig-size="1022,700" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="vsphere-contetn-library-deployment-models-1" data-image-description="" data-medium-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-1.png?fit=300%2C205" data-large-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-1.png?fit=770%2C527" class="alignnone wp-image-159528" src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2017/11/vsphere-contetn-library-deployment-models-1.png?resize=770%2C527&#038;ssl=1" alt="" data-recalc-dims="1" /></noscript></a></p>
<p>The added advantage with this deployment is that if your primary vCenter Server is unavailable, each remote location is unaffected and will be able to continue provisioning and have access to their local Content Library. In addition, if Enhanced Linked Mode is configured across the vCenter Servers and the ESXi hosts can communicate with each other, then Content Library replication will take place between host-to-host via NFC rather than over HTTP(s) between the vCenter Servers which can take advantage of things like VAAI for more efficient transfers.</p>
<p>As you can see in both scenarios, the characteristics of centralized content management, content distribution and optimal workload deployment from Content Library are exactly the same and can be achieved regardless if you have a single or multiple vCenter Server(s). Lastly, if you have more efficient method of replicating large amounts of data across your datacenter (array or network based tools), you also have the option of externally replicating your Content Library, have a look at this blog post <a href="https://www.virtuallyghetto.com/2017/11/external-replication-of-vsphere-content-library.html" target="_blank" rel="noopener">here</a> for more details.</p>
<div class="wp_rp_wrap  wp_rp_vertical_m" id="wp_rp_first"><div class="wp_rp_content"><h3 class="related_post_title">More from my site</h3><ul class="related_post wp_rp"><li data-position="0" data-poid="in-22240" data-post-type="none"><a href="https://www.virtuallyghetto.com/2017/03/maximum-number-of-vcenter-servers-per-single-sign-on-sso-domain.html" class="wp_rp_title">Maximum number of vCenter Servers per Single Sign-On (SSO) Domain</a></li><li data-position="1" data-poid="in-21303" data-post-type="none"><a href="https://www.virtuallyghetto.com/2017/01/exploring-new-vcsa-vami-api-wpowercli-part-1.html" class="wp_rp_title">Exploring new VCSA VAMI API w/PowerCLI: Part 1</a></li><li data-position="2" data-poid="in-13691" data-post-type="none"><a href="https://www.virtuallyghetto.com/2015/06/creating-your-own-3rd-party-content-library-for-vsphere-6-0-vcloud-director-5-x.html" class="wp_rp_title">Creating your own 3rd Party Content Library for vSphere 6.0 &#038; vCloud Director 5.x</a></li><li data-position="3" data-poid="in-22624" data-post-type="none"><a href="https://www.virtuallyghetto.com/2017/04/new-vsan-management-6-6-api-sdks-clis.html" class="wp_rp_title">New vSAN Management 6.6 API / SDKs / CLIs</a></li><li data-position="4" data-poid="in-13061" data-post-type="none"><a href="https://www.virtuallyghetto.com/2015/04/subscribe-to-vghetto-nested-esxi-template-content-library-in-vsphere-6-0.html" class="wp_rp_title">Subscribe to vGhetto Nested ESXi Template Content Library in vSphere 6.0</a></li><li data-position="5" data-poid="in-21400" data-post-type="none"><a href="https://www.virtuallyghetto.com/2017/01/exploring-new-vcsa-vami-api-wpowercli-part-2.html" class="wp_rp_title">Exploring new VCSA VAMI API w/PowerCLI: Part 2</a></li></ul></div></div>
<div class="ssba ssba-wrap"><div style="text-align:left"><a href="https://simplesharebuttons.com" target="_blank">Be Sociable, Share</a><a data-site="" class="ssba_twitter_share" href="https://twitter.com/share?url=http://www.virtuallyghetto.com/2017/12/deployment-models-for-vsphere-content-library.html&amp;text=Deployment%20models%20for%20vSphere%20Content%20Library%20" target=&quot;_blank&quot;><img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/twitter.png?w=770" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" data-recalc-dims="1" /><noscript><img src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/twitter.png?w=770" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" data-recalc-dims="1" /></noscript></a><a data-site="" class="ssba_facebook_share" href="https://www.facebook.com/sharer.php?u=http://www.virtuallyghetto.com/2017/12/deployment-models-for-vsphere-content-library.html" target="_blank"><img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/facebook.png?w=770" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" data-recalc-dims="1" /><noscript><img src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/facebook.png?w=770" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" data-recalc-dims="1" /></noscript></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=http://www.virtuallyghetto.com/2017/12/deployment-models-for-vsphere-content-library.html" target=&quot;_blank&quot;><img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/linkedin.png?w=770" title="LinkedIn" class="ssba ssba-img" alt="Share on LinkedIn" data-recalc-dims="1" /><noscript><img src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/linkedin.png?w=770" title="LinkedIn" class="ssba ssba-img" alt="Share on LinkedIn" data-recalc-dims="1" /></noscript></a><a data-site="" class="ssba_google_share" href="https://plus.google.com/share?url=http://www.virtuallyghetto.com/2017/12/deployment-models-for-vsphere-content-library.html" target=&quot;_blank&quot;><img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/google.png?w=770" title="Google+" class="ssba ssba-img" alt="Share on Google+" data-recalc-dims="1" /><noscript><img src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/google.png?w=770" title="Google+" class="ssba ssba-img" alt="Share on Google+" data-recalc-dims="1" /></noscript></a><a data-site='pinterest' class='ssba_pinterest_share' href='javascript:void((function()%7Bvar%20e=document.createElement(&apos;script&apos;);e.setAttribute(&apos;type&apos;,&apos;text/javascript&apos;);e.setAttribute(&apos;charset&apos;,&apos;UTF-8&apos;);e.setAttribute(&apos;src&apos;,&apos;//assets.pinterest.com/js/pinmarklet.js?r=&apos;+Math.random()*99999999);document.body.appendChild(e)%7D)());'><img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/pinterest.png?w=770" title="Pinterest" class="ssba ssba-img" alt="Pin on Pinterest" data-recalc-dims="1" /><noscript><img src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/pinterest.png?w=770" title="Pinterest" class="ssba ssba-img" alt="Pin on Pinterest" data-recalc-dims="1" /></noscript></a><a data-site="reddit" class="ssba_reddit_share" href="https://reddit.com/submit?url=http://www.virtuallyghetto.com/2017/12/deployment-models-for-vsphere-content-library.html&amp;title=Deployment models for vSphere Content Library" target=&quot;_blank&quot;><img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/reddit.png?w=770" title="Reddit" class="ssba ssba-img" alt="Share on Reddit" data-recalc-dims="1" /><noscript><img src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/reddit.png?w=770" title="Reddit" class="ssba ssba-img" alt="Share on Reddit" data-recalc-dims="1" /></noscript></a></div></div> </div>
<footer class="entry-meta">
Category: <a href="https://www.virtuallyghetto.com/category/vsphere" rel="category tag">vSphere</a>, <a href="https://www.virtuallyghetto.com/category/vsphere-6-0" rel="category tag">vSphere 6.0</a>, <a href="https://www.virtuallyghetto.com/category/vsphere-6-5" rel="category tag">vSphere 6.5</a> Tags: <a href="https://www.virtuallyghetto.com/tag/content-library" rel="tag">content library</a>, <a href="https://www.virtuallyghetto.com/tag/vsphere-6-0" rel="tag">vSphere 6.0</a>, <a href="https://www.virtuallyghetto.com/tag/vsphere-6-5" rel="tag">vSphere 6.5</a>
</footer>
</article>
<nav role="navigation" id="nav-below" class="navigation-post">
<h1 class="screen-reader-text">Post navigation</h1>
<div class="nav-previous"><a href="https://www.virtuallyghetto.com/2017/11/how-to-audit-vsphere-api-usage.html" rel="prev"><span class="meta-nav">&larr;</span> How to audit vSphere API usage?</a></div>
</nav>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Thanks for the comment! <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/12/deployment-models-for-vsphere-content-library.html#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=67295360&#038;postid=159522&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=retro&#038;greeting=Thanks+for+the+comment%21&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=5.5.1&#038;sig=2766dfc1bff8c5d8be760f805122de0ae1664536#parent=http%3A%2F%2Fwww.virtuallyghetto.com%2F2017%2F12%2Fdeployment-models-for-vsphere-content-library.html" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
<!--[if !IE]><!-->
<script>
					document.addEventListener('DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName('jetpack_remote_comment');
						for (var i = 0; i < commentForms.length; i++) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					});
				</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div>
<div id="secondary" class="widget-area" role="complementary">
<aside id="text-5" class="widget widget_text"> <div class="textwidget"><div class="circular_author"></div>
<center><b>William Lam</b></center></div>
</aside><aside id="simple-social-icons-4" class="widget simple-social-icons"><ul class="aligncenter"><li class="ssi-github"><a href="https://github.com/lamw" target="_blank"><svg role="img" class="social-github" aria-labelledby="social-github"><title id="social-github">Github</title><use xlink:href="http://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-github"></use></svg></a></li><li class="ssi-gplus"><a href="https://plus.google.com/114142893306148938477" target="_blank"><svg role="img" class="social-gplus" aria-labelledby="social-gplus"><title id="social-gplus">Google+</title><use xlink:href="http://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-gplus"></use></svg></a></li><li class="ssi-linkedin"><a href="https://www.linkedin.com/in/lamwilliam/" target="_blank"><svg role="img" class="social-linkedin" aria-labelledby="social-linkedin"><title id="social-linkedin">Linkedin</title><use xlink:href="http://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-linkedin"></use></svg></a></li><li class="ssi-rss"><a href="https://www.virtuallyghetto.com/rss" target="_blank"><svg role="img" class="social-rss" aria-labelledby="social-rss"><title id="social-rss">RSS</title><use xlink:href="http://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-rss"></use></svg></a></li><li class="ssi-twitter"><a href="https://twitter.com/lamw" target="_blank"><svg role="img" class="social-twitter" aria-labelledby="social-twitter"><title id="social-twitter">Twitter</title><use xlink:href="http://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li></ul></aside><aside id="search-5" class="widget widget_search"> <form method="get" id="searchform" class="searchform" action="https://www.virtuallyghetto.com/" role="search">
<label for="s" class="screen-reader-text">Search</label>
<input type="search" class="field" name="s" value="" id="s" placeholder="Search &hellip;" />
<input type="submit" class="submit" id="searchsubmit" value="Search" />
</form>
</aside><aside id="bsa-6" class="widget widget_bsa">

<div id="bsap_1282588" class="bsarocks bsap_6d274f0434e88e8f84574d74902bc1c4"></div>

</aside> </div>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="site-info">
<a href="https://wordpress.org/" title="A Semantic Personal Publishing Platform" rel="generator">Proudly powered by WordPress</a>
<span class="sep"> | </span>
Theme: m1 Theme by <a href="http://m1themes.com" title="m1 Themes" rel="designer">m1 Themes</a>. </div>
</footer>
</div>
<script>window.lazyLoadOptions = {
		elements_selector: "img, iframe",
		data_src: "lazy-src",
		data_srcset: "lazy-srcset",
		class_loading: "lazyloading",
		class_loaded: "lazyloaded",
		threshold: 300,
		callback_load: function(element) {
			if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
				if (element.classList.contains("lazyloaded") ) {
					if (typeof window.jQuery != 'undefined') {
						if (jQuery.fn.fitVids) {
							jQuery(element).parent().fitVids();
						}
					}
				}
			}
		}	
	};</script> <script>function lazyLoadThumb(e){var t='<img src="https://i.ytimg.com/vi/ID/hqdefault.jpg">',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="https://www.youtube.com/embed/ID?autoplay=1";e.setAttribute("src",t.replace("ID",this.dataset.id)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script> <script type="text/javascript">
  analytics.track("Viewed Post", {"title":"Deployment models for vSphere Content Library","category":"vSphere, vSphere 6.0, vSphere 6.5","noninteraction":true}, {"library":"analytics-wordpress"});
    
</script>
<div style="display:none">
</div>
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='http://www.virtuallyghetto.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='simple-share-buttons-adder-ssba-css' href="https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=4.9.1" type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									
									
									
									
								}
								.ssba img
								{
									width: 35px !important;
									padding: 6px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								.ssba .fb-save
								{
								padding: 6px;
								line-height: 30px;
								}
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 20px;
									
									
								}
								
</style>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122"></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201748'></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.js?ver=4.9.1"></script>
<script type='text/javascript'>
Main.boot( [] );
</script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/themes/m1/js/skip-link-focus-fix.js?ver=20130115"></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-includes/js/comment-reply.min.js?ver=4.9.1"></script>
<script async data-minify="1" type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/plugins/rocket-lazy-load/assets/js/lazyload-8.2.min.js"></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-includes/js/wp-embed.min.js?ver=4.9.1"></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/spin.js?ver=1.3"></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/jquery.spin.js?ver=1.3"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/www.virtuallyghetto.com\/wp-admin\/admin-ajax.php","nonce":"a2a8826e1a","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"http:\/\/www.virtuallyghetto.com\/wp-login.php?redirect_to=http%3A%2F%2Fwww.virtuallyghetto.com%2F2017%2F12%2Fdeployment-models-for-vsphere-content-library.html","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.js?ver=20170209"></script>
<script async="async" type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.1"></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/client/js/prod/lib.core.js?ver=2.6.0"></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/client/js/prod/lib.view.js?ver=2.6.0"></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/themes/baseline/js/prod/client.js?ver=2.6.0"></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/themes/default/js/prod/client.js?ver=2.6.0"></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/template-tags/item/js/prod/tag.item.js?ver=2.6.0"></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/template-tags/ui/js/prod/tag.ui.js?ver=2.6.0"></script>
<script type='text/javascript' src="https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/content-handlers/image/js/prod/handler.image.js?ver=2.6.0"></script>
<script type="text/javascript" id="slb_footer">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB && SLB.has_child('View.init') ) { SLB.View.init({"ui_autofit":true,"ui_animate":true,"slideshow_autostart":true,"slideshow_duration":"6","group_loop":true,"ui_overlay_opacity":"0.8","ui_title_default":false,"theme_default":"slb_default","ui_labels":{"loading":"Loading","close":"Close","nav_next":"Next","nav_prev":"Previous","slideshow_start":"Start slideshow","slideshow_stop":"Stop slideshow","group_status":"Item %current% of %total%"}}); }
if ( !!window.SLB && SLB.has_child('View.assets') ) { {$.extend(SLB.View.assets, {"1433466157":{"id":null,"type":"image","source":"https:\/\/www.virtuallyghetto.com\/wp-content\/uploads\/2017\/11\/vsphere-contetn-library-deployment-models-0.png","internal":true},"1649777321":{"id":null,"type":"image","source":"https:\/\/www.virtuallyghetto.com\/wp-content\/uploads\/2017\/11\/vsphere-contetn-library-deployment-models-1.png","internal":true}});} }
/* THM */
if ( !!window.SLB && SLB.has_child('View.extend_theme') ) { SLB.View.extend_theme('slb_baseline',{"name":"Baseline","parent":"","styles":[{"handle":"base","uri":"http:\/\/www.virtuallyghetto.com\/wp-content\/plugins\/simple-lightbox\/themes\/baseline\/css\/style.css","deps":[]}],"layout_raw":"<div class=\"slb_container\"><div class=\"slb_content\">{{item.content}}<div class=\"slb_nav\"><span class=\"slb_prev\">{{ui.nav_prev}}<\/span><span class=\"slb_next\">{{ui.nav_next}}<\/span><\/div><div class=\"slb_controls\"><span class=\"slb_close\">{{ui.close}}<\/span><span class=\"slb_slideshow\">{{ui.slideshow_control}}<\/span><\/div><div class=\"slb_loading\">{{ui.loading}}<\/div><\/div><div class=\"slb_details\"><div class=\"inner\"><div class=\"slb_data\"><div class=\"slb_data_content\"><span class=\"slb_data_title\">{{item.title}}<\/span><span class=\"slb_group_status\">{{ui.group_status}}<\/span><div class=\"slb_data_desc\">{{item.description}}<\/div><\/div><\/div><div class=\"slb_nav\"><span class=\"slb_prev\">{{ui.nav_prev}}<\/span><span class=\"slb_next\">{{ui.nav_next}}<\/span><\/div><\/div><\/div><\/div>"}); }if ( !!window.SLB && SLB.has_child('View.extend_theme') ) { SLB.View.extend_theme('slb_default',{"name":"Default (Light)","parent":"slb_baseline","styles":[{"handle":"font","uri":"http:\/\/fonts.googleapis.com\/css?family=Yanone+Kaffeesatz","deps":[]},{"handle":"base","uri":"http:\/\/www.virtuallyghetto.com\/wp-content\/plugins\/simple-lightbox\/themes\/default\/css\/style.css","deps":[]}]}); }})})(jQuery);}/* ]]> */</script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=67295360&postid=159522&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=retro&greeting=Thanks+for+the+comment%21&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.5.1&sig=2766dfc1bff8c5d8be760f805122de0ae1664536#parent=http%3A%2F%2Fwww.virtuallyghetto.com%2F2017%2F12%2Fdeployment-models-for-vsphere-content-library.html" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=67295360&postid=159522&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=retro&greeting=Thanks+for+the+comment%21&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.5.1&sig=2766dfc1bff8c5d8be760f805122de0ae1664536#parent=http%3A%2F%2Fwww.virtuallyghetto.com%2F2017%2F12%2Fdeployment-models-for-vsphere-content-library.html";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "http:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script type='text/javascript' src='https://stats.wp.com/e-201748.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.5.1',blog:'67295360',post:'159522',tz:'-8',srv:'www.virtuallyghetto.com'} ]);
	_stq.push([ 'clickTrackerInit', '67295360', '159522' ]);
</script>
</body>
</html>
