<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name="robots" content="noodp,noydir" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Automating VMware Site Recovery (DRaaS) with VMC</title>
<script>(function(d, s, id){
				 var js, fjs = d.getElementsByTagName(s)[0];
				 if (d.getElementById(id)) {return;}
				 js = d.createElement(s); js.id = id;
				 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
				 fjs.parentNode.insertBefore(js, fjs);
			   }(document, 'script', 'facebook-jssdk'));</script><link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//ws.sharethis.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="virtuallyGhetto &raquo; Feed" href="https://www.virtuallyghetto.com/feed" />
<link rel="alternate" type="application/rss+xml" title="virtuallyGhetto &raquo; Comments Feed" href="https://www.virtuallyghetto.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="virtuallyGhetto &raquo; Automating VMware Site Recovery (DRaaS) with VMC Comments Feed" href="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/feed" />
<link rel="canonical" href="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.virtuallyghetto.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='crayon-css' href='https://www.virtuallyghetto.com/wp-content/plugins/crayon-syntax-highlighter/css/min/crayon.min.css?ver=_2.7.2_beta' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-sample-css' href='https://www.virtuallyghetto.com/wp-content/themes/genesis-sample/style.css?ver=2.6.0' type='text/css' media='all' />
<style id='genesis-sample-inline-css' type='text/css'>


		a,
		.entry-title a:focus,
		.entry-title a:hover,
		.genesis-nav-menu a:focus,
		.genesis-nav-menu a:hover,
		.genesis-nav-menu .current-menu-item > a,
		.genesis-nav-menu .sub-menu .current-menu-item > a:focus,
		.genesis-nav-menu .sub-menu .current-menu-item > a:hover,
		.menu-toggle:focus,
		.menu-toggle:hover,
		.sub-menu-toggle:focus,
		.sub-menu-toggle:hover {
			color: #830101;
		}

		

		button:focus,
		button:hover,
		input[type="button"]:focus,
		input[type="button"]:hover,
		input[type="reset"]:focus,
		input[type="reset"]:hover,
		input[type="submit"]:focus,
		input[type="submit"]:hover,
		input[type="reset"]:focus,
		input[type="reset"]:hover,
		input[type="submit"]:focus,
		input[type="submit"]:hover,
		.button:focus,
		.button:hover,
		.genesis-nav-menu > .menu-highlight > a:hover,
		.genesis-nav-menu > .menu-highlight > a:focus,
		.genesis-nav-menu > .menu-highlight.current-menu-item > a {
			background-color: #830101;
			color: #ffffff;
		}
		
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.virtuallyghetto.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='easy_author_image-css' href='https://www.virtuallyghetto.com/wp-content/plugins/easy-author-image/css/easy-author-image.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-sample-fonts-css' href='//fonts.googleapis.com/css?family=Source+Sans+Pro%3A400%2C400i%2C600%2C700&#038;ver=2.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://www.virtuallyghetto.com/wp-includes/css/dashicons.min.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css' href='https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/css/style.css?ver=3.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css' href='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='easy_table_style-css' href='https://www.virtuallyghetto.com/wp-content/plugins/easy-table/themes/cuscosky/style.css?ver=1.8' type='text/css' media='all' />
<link rel='stylesheet' id='open-sans-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.3.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var CrayonSyntaxSettings = {"version":"_2.7.2_beta","is_admin":"0","ajaxurl":"https:\/\/www.virtuallyghetto.com\/wp-admin\/admin-ajax.php","prefix":"crayon-","setting":"crayon-setting","selected":"crayon-setting-selected","changed":"crayon-setting-changed","special":"crayon-setting-special","orig_value":"data-orig-value","debug":""};
var CrayonSyntaxStrings = {"copy":"Press %s to Copy, %s to Paste","minimize":"Click To Expand Code"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/crayon-syntax-highlighter/js/min/crayon.min.js?ver=_2.7.2_beta'></script>
<script id='st_insights_js' type='text/javascript' src='https://ws.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=7.3.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=7.3.1'></script>
<link rel='https://api.w.org/' href='https://www.virtuallyghetto.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.virtuallyghetto.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="https://www.virtuallyghetto.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.virtuallyghetto.com%2F2019%2F05%2Fautomating-vmware-site-recovery-draas-with-vmc.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.virtuallyghetto.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.virtuallyghetto.com%2F2019%2F05%2Fautomating-vmware-site-recovery-draas-with-vmc.html&#038;format=xml" />

<script type="text/javascript">
        (function(){
          var bsa = document.createElement('script');
              bsa.type= 'text/javascript';
              bsa.async = true;
              bsa.src='//s3.buysellads.com/ac/bsa.js';
          (document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(bsa);
        })();
        </script>

<script type="text/javascript">
	window._wp_rp_static_base_url = 'https://wprp.zemanta.com/static/';
	window._wp_rp_wp_ajax_url = "https://www.virtuallyghetto.com/wp-admin/admin-ajax.php";
	window._wp_rp_plugin_version = '3.6.4';
	window._wp_rp_post_id = '165204';
	window._wp_rp_num_rel_posts = '5';
	window._wp_rp_thumbnails = false;
	window._wp_rp_post_title = 'Automating+VMware+Site+Recovery+%28DRaaS%29+with+VMC';
	window._wp_rp_post_tags = ['site+recovery+manager', 'vmware+cloud+on+aws', 'srm', 'draas', 'vmware+site+recovery', 'vmc', 'automation', 'powercli', 'vmware+cloud+on+aws', 'alt', 'featur', 'api', 'dr', 'a', 'vmware', 'recoveri', 'autom', 'custom', 'aa', 'show', 'cloud', 'servic', 'disast', 'consol'];
	window._wp_rp_promoted_content = true;
</script>

<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>

<meta property="og:type" content="article" />
<meta property="og:title" content="Automating VMware Site Recovery (DRaaS) with VMC" />
<meta property="og:url" content="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html" />
<meta property="og:description" content="VMware Site Recovery provides customers with an easy and on-demand Disaster Recovery as-as-Service (DRaaS) for both their on-premises and VMware Cloud on AWS (VMC) workloads. DRaaS is one of the mo…" />
<meta property="article:published_time" content="2019-05-28T16:11:20+00:00" />
<meta property="article:modified_time" content="2019-05-28T16:11:20+00:00" />
<meta property="og:site_name" content="virtuallyGhetto" />
<meta property="og:image" content="https://www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9-1024x426.png" />
<meta property="og:image:width" content="702" />
<meta property="og:image:height" content="292" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Automating VMware Site Recovery (DRaaS) with VMC" />
<meta name="twitter:card" content="summary" />

<link rel="icon" href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=240%2C240&#038;ssl=1" />
<style type="text/css" id="wp-custom-css">
				.terminal {
	border: 1px grey dashed;
	padding: 10px;
	background-color: whiteSmoke;
	color: black;
	font-family: "Lucida Console", Monaco, monospace;
	font-size: small;
}			</style>
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-165204 single-format-standard header-full-width content-sidebar" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://www.virtuallyghetto.com/">virtuallyGhetto</a></p></div><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary"><div class="wrap"><ul id="menu-main" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-510" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-510"><a href="https://www.virtuallyghetto.com/about" itemprop="url"><span itemprop="name">About</span></a></li>
<li id="menu-item-161462" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-161462"><a href="https://www.virtuallyghetto.com/privacy-policy" itemprop="url"><span itemprop="name">Privacy</span></a></li>
<li id="menu-item-165250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-165250"><a href="https://www.virtuallyghetto.com/vmware-cloud-on-aws" itemprop="url"><span itemprop="name">VMware Cloud on AWS</span></a></li>
<li id="menu-item-165282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-165282"><a href="https://www.virtuallyghetto.com/home-lab" itemprop="url"><span itemprop="name">Home Lab</span></a></li>
<li id="menu-item-760" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-760"><a href="#" itemprop="url"><span itemprop="name">Automation</span></a>
<ul class="sub-menu">
<li id="menu-item-591" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-591"><a href="https://www.virtuallyghetto.com/vmware-kickstart" itemprop="url"><span itemprop="name">VMware Kickstart</span></a></li>
<li id="menu-item-593" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-593"><a href="https://www.virtuallyghetto.com/kickstart" itemprop="url"><span itemprop="name">VMware API/SDK/CLI</span></a></li>
<li id="menu-item-592" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-592"><a href="https://www.virtuallyghetto.com/vmware-vmavima" itemprop="url"><span itemprop="name">VMware vMA/VIMA</span></a></li>
<li id="menu-item-13682" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13682"><a href="https://www.virtuallyghetto.com/ovf" itemprop="url"><span itemprop="name">VMware OVF / OVFTOOL</span></a></li>
</ul>
</li>
<li id="menu-item-450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-450"><a href="https://www.virtuallyghetto.com/nested-virtualization" itemprop="url"><span itemprop="name">Nested Virtualization</span></a></li>
<li id="menu-item-448" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-448"><a href="https://www.virtuallyghetto.com/apple" itemprop="url"><span itemprop="name">Apple Mac</span></a></li>
<li id="menu-item-449" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-449"><a href="https://www.virtuallyghetto.com/vcsa" itemprop="url"><span itemprop="name">VCSA</span></a></li>
<li id="menu-item-10631" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10631"><a href="https://www.virtuallyghetto.com/vsan" itemprop="url"><span itemprop="name">VSAN</span></a></li>
</ul></div></nav></div></header><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://www.virtuallyghetto.com/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Home</span></a><meta itemprop="position" content="1"></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://www.virtuallyghetto.com/category/automation" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Automation</span></a><meta itemprop="position" content="2"></span> <span aria-label="breadcrumb separator">/</span> Automating VMware Site Recovery (DRaaS) with VMC</div><article class="post-165204 post type-post status-publish format-standard category-automation category-powercli category-vmware-cloud-on-aws tag-draas tag-site-recovery-manager tag-srm-2 tag-vmc tag-vmware-cloud-on-aws tag-vmware-site-recovery entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Automating VMware Site Recovery (DRaaS) with VMC</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2019-05-28T09:11:20-07:00">05/28/2019</time> by <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://www.virtuallyghetto.com/author/lamw" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">William Lam</span></a></span> <span class="entry-comments-link"><a href="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text"><p><a href="https://cloud.vmware.com/vmware-site-recovery" target="_blank" rel="noopener noreferrer">VMware Site Recovery</a> provides customers with an easy and on-demand Disaster Recovery as-as-Service (DRaaS) for both their on-premises and VMware Cloud on AWS (VMC) workloads. DRaaS is one of the most popular VMware Cloud Service as it literally enables customers to setup a fully functional target DR site with just a click of a button, no joke!</p>
<p><a href="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?ssl=1" data-slb-active="1" data-slb-asset="1913302972" data-slb-internal="0" data-slb-group="165204"><img data-attachment-id="165212" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-1" data-orig-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?fit=2546%2C696&amp;ssl=1" data-orig-size="2546,696" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-1" data-image-description data-medium-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?fit=300%2C82&amp;ssl=1" data-large-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?fit=702%2C192&amp;ssl=1" class="alignnone size-large wp-image-165212 jetpack-lazy-image" src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?resize=702%2C192&#038;ssl=1" alt width="702" height="192" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?resize=1024%2C280&amp;ssl=1 1024w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?resize=300%2C82&amp;ssl=1 300w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?resize=768%2C210&amp;ssl=1 768w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?w=1404&amp;ssl=1 1404w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?w=2106&amp;ssl=1 2106w" data-lazy-sizes="(max-width: 702px) 100vw, 702px" data-lazy-src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?resize=702%2C192&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="165212" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-1" data-orig-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?fit=2546%2C696&amp;ssl=1" data-orig-size="2546,696" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-1" data-image-description="" data-medium-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?fit=300%2C82&amp;ssl=1" data-large-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?fit=702%2C192&amp;ssl=1" class="alignnone size-large wp-image-165212" src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?resize=702%2C192&#038;ssl=1" alt="" width="702" height="192" srcset="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?resize=1024%2C280&amp;ssl=1 1024w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?resize=300%2C82&amp;ssl=1 300w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?resize=768%2C210&amp;ssl=1 768w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?w=1404&amp;ssl=1 1404w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-1.png?w=2106&amp;ssl=1 2106w" sizes="(max-width: 702px) 100vw, 702px" data-recalc-dims="1" /></noscript></a><br />
As simple as this is, customers are also interested in automating the setup of DRaaS, especially for testing purposes. A couple of weeks back, I had a customer reach out asking if it was possible to automate the setup of DRaaS?</p>
<p>Funny enough, I just had this conversation a few weeks prior with the PM/Engineer and was in the process of looking into this. It turns out we do indeed have DRaaS Service API, which is what the VMC Console uses, however we had not publicized the API nor showed how to actually get more information about it. Do not worry, I have already feature request with the PM to not only get this published publicly but also show up as part of the VMC Developer Center API Explorer 🙂</p>
<p><span id="more-165204"></span></p>
<p>The DRaaS Service API is pretty straight forward to use and there are only key three methods that are required for the basic DRaaS workflows. Below is a screenshot of the Swagger file, which can be downloaded using cURL as it requires authentication and you can use this shell script <a href="https://github.com/lamw/vghetto-scripts/blob/master/shell/download_draas_swagger_json.sh" target="_blank" rel="noopener noreferrer">here</a> to do so. Once downloaded, you can use any Swagger-based tool to view it, I use the <a href="https://editor.swagger.io" target="_blank" rel="noopener noreferrer">Swagger Online Editor</a> for this.</p>
<p><a href="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?ssl=1" data-slb-active="1" data-slb-asset="1255299890" data-slb-internal="0" data-slb-group="165204"><img data-attachment-id="165213" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-0" data-orig-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?fit=1888%2C882&amp;ssl=1" data-orig-size="1888,882" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-0" data-image-description data-medium-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?fit=300%2C140&amp;ssl=1" data-large-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?fit=702%2C328&amp;ssl=1" class="alignnone size-large wp-image-165213 jetpack-lazy-image" src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?resize=702%2C328&#038;ssl=1" alt width="702" height="328" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?resize=1024%2C478&amp;ssl=1 1024w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?resize=300%2C140&amp;ssl=1 300w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?resize=768%2C359&amp;ssl=1 768w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?w=1404&amp;ssl=1 1404w" data-lazy-sizes="(max-width: 702px) 100vw, 702px" data-lazy-src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?resize=702%2C328&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="165213" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-0" data-orig-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?fit=1888%2C882&amp;ssl=1" data-orig-size="1888,882" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-0" data-image-description="" data-medium-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?fit=300%2C140&amp;ssl=1" data-large-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?fit=702%2C328&amp;ssl=1" class="alignnone size-large wp-image-165213" src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?resize=702%2C328&#038;ssl=1" alt="" width="702" height="328" srcset="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?resize=1024%2C478&amp;ssl=1 1024w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?resize=300%2C140&amp;ssl=1 300w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?resize=768%2C359&amp;ssl=1 768w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-0.png?w=1404&amp;ssl=1 1404w" sizes="(max-width: 702px) 100vw, 702px" data-recalc-dims="1" /></noscript></a><br />
Rather than talking about how the DRaaS API works, lets take a look at an actual implementation! Similiar to <a href="https://github.com/lamw/PowerCLI-Example-Scripts/tree/master/Modules/VMware.VMC" target="_blank" rel="noopener noreferrer">VMC</a>, <a href="https://github.com/lamw/PowerCLI-Example-Scripts/tree/master/Modules/VMware.VMC.NSXT" target="_blank" rel="noopener noreferrer">VMC NSX-T</a> and <a href="https://github.com/lamw/PowerCLI-Example-Scripts/tree/master/Modules/VMware.HCX" target="_blank" rel="noopener noreferrer">VMC HCX</a> Community PowerCLI Module, I have also created a module for DRaaS which just contains three functions:</p>
<ul>
<li><strong>Connect-DRaas</strong></li>
<li><strong>Get-DRaas</strong></li>
<li><strong>Set-DRaas</strong></li>
</ul>
<p><a href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?ssl=1" data-slb-active="1" data-slb-asset="886316975" data-slb-internal="0" data-slb-group="165204"><img data-attachment-id="165230" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-2" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?fit=1998%2C412&amp;ssl=1" data-orig-size="1998,412" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-2" data-image-description data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?fit=300%2C62&amp;ssl=1" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?fit=702%2C145&amp;ssl=1" class="alignnone size-large wp-image-165230 jetpack-lazy-image" src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?resize=702%2C145&#038;ssl=1" alt width="702" height="145" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?resize=1024%2C211&amp;ssl=1 1024w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?resize=300%2C62&amp;ssl=1 300w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?resize=768%2C158&amp;ssl=1 768w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?w=1404&amp;ssl=1 1404w" data-lazy-sizes="(max-width: 702px) 100vw, 702px" data-lazy-src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?resize=702%2C145&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="165230" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-2" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?fit=1998%2C412&amp;ssl=1" data-orig-size="1998,412" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-2" data-image-description="" data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?fit=300%2C62&amp;ssl=1" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?fit=702%2C145&amp;ssl=1" class="alignnone size-large wp-image-165230" src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?resize=702%2C145&#038;ssl=1" alt="" width="702" height="145" srcset="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?resize=1024%2C211&amp;ssl=1 1024w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?resize=300%2C62&amp;ssl=1 300w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?resize=768%2C158&amp;ssl=1 768w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-2.png?w=1404&amp;ssl=1 1404w" sizes="(max-width: 702px) 100vw, 702px" data-recalc-dims="1" /></noscript></a><br />
For more details on how to use the DRaaS module, check out the tutorial below.</p>
<p><strong>Step 1</strong> - Download and import the <a href="https://github.com/vmware/PowerCLI-Example-Scripts/tree/master/Modules/VMware.VMC" target="_blank" rel="noopener noreferrer">VMC Community PowerCLI Module</a></p>
<p class="terminal">Import-Module ./VMware.VMC.psd1</p>
<p><strong>Step 2</strong> - Connect to the VMC service and provide your VMC Organization Refresh Token, Name and SDDC Name by running the following commands:</p>
<p class="terminal">$RefreshToken = "FILL-ME-IN"<br />
$OrgName = "BashFest - Red Team"<br />
$SDDCName = "SDDC-02"<br />
Connect-VmcServer -RefreshToken $RefreshToken</p>
<p><strong>Step 3</strong> - Download and import the <a href="https://github.com/lamw/PowerCLI-Example-Scripts/tree/master/Modules/VMware.DRaaS" target="_blank" rel="noopener noreferrer">DRaaS Community PowerCLI Module</a> and connect to the service by running the following commands:</p>
<p class="terminal">Import ./VMware.DRaaS.psd1<br />
Connect-DRaas -RefreshToken $RefreshToken -OrgName $OrgName -SDDCName $SDDCName</p>
<p><strong>Step 4</strong> - Once you have successfully connected, we can use the <strong>Get-DRaas</strong> function to get information about our DRaas deployment. If you have not activated DRaaS, you will get a message like the one shown below to use the Set-DRaas function to do so.</p>
<p class="terminal">Get-DRaas</p>
<p><a href="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?ssl=1" data-slb-active="1" data-slb-asset="1378847437" data-slb-internal="0" data-slb-group="165204"><img data-attachment-id="165214" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-3" data-orig-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?fit=1502%2C222&amp;ssl=1" data-orig-size="1502,222" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-3" data-image-description data-medium-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?fit=300%2C44&amp;ssl=1" data-large-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?fit=702%2C104&amp;ssl=1" class="alignnone size-large wp-image-165214 jetpack-lazy-image" src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?resize=702%2C104&#038;ssl=1" alt width="702" height="104" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?resize=1024%2C151&amp;ssl=1 1024w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?resize=300%2C44&amp;ssl=1 300w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?resize=768%2C114&amp;ssl=1 768w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?w=1502&amp;ssl=1 1502w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?w=1404&amp;ssl=1 1404w" data-lazy-sizes="(max-width: 702px) 100vw, 702px" data-lazy-src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?resize=702%2C104&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="165214" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-3" data-orig-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?fit=1502%2C222&amp;ssl=1" data-orig-size="1502,222" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-3" data-image-description="" data-medium-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?fit=300%2C44&amp;ssl=1" data-large-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?fit=702%2C104&amp;ssl=1" class="alignnone size-large wp-image-165214" src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?resize=702%2C104&#038;ssl=1" alt="" width="702" height="104" srcset="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?resize=1024%2C151&amp;ssl=1 1024w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?resize=300%2C44&amp;ssl=1 300w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?resize=768%2C114&amp;ssl=1 768w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?w=1502&amp;ssl=1 1502w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-3.png?w=1404&amp;ssl=1 1404w" sizes="(max-width: 702px) 100vw, 702px" data-recalc-dims="1" /></noscript></a><br />
<strong>Step 6</strong> - Lets go ahead and activate DRaas by using the <strong>Set-DRaas</strong> function and specify the <strong>-Activate</strong> flag by running the following command:</p>
<p class="terminal">Set-DRaas -Activate</p>
<p><a href="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?ssl=1" data-slb-active="1" data-slb-asset="1143669800" data-slb-internal="0" data-slb-group="165204"><img data-attachment-id="165215" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-4" data-orig-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?fit=2640%2C220&amp;ssl=1" data-orig-size="2640,220" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-4" data-image-description data-medium-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?fit=300%2C25&amp;ssl=1" data-large-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?fit=702%2C58&amp;ssl=1" class="alignnone size-large wp-image-165215 jetpack-lazy-image" src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?resize=702%2C58&#038;ssl=1" alt width="702" height="58" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?resize=1024%2C85&amp;ssl=1 1024w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?resize=300%2C25&amp;ssl=1 300w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?resize=768%2C64&amp;ssl=1 768w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?w=1404&amp;ssl=1 1404w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?w=2106&amp;ssl=1 2106w" data-lazy-sizes="(max-width: 702px) 100vw, 702px" data-lazy-src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?resize=702%2C58&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="165215" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-4" data-orig-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?fit=2640%2C220&amp;ssl=1" data-orig-size="2640,220" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-4" data-image-description="" data-medium-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?fit=300%2C25&amp;ssl=1" data-large-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?fit=702%2C58&amp;ssl=1" class="alignnone size-large wp-image-165215" src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?resize=702%2C58&#038;ssl=1" alt="" width="702" height="58" srcset="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?resize=1024%2C85&amp;ssl=1 1024w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?resize=300%2C25&amp;ssl=1 300w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?resize=768%2C64&amp;ssl=1 768w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?w=1404&amp;ssl=1 1404w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-4.png?w=2106&amp;ssl=1 2106w" sizes="(max-width: 702px) 100vw, 702px" data-recalc-dims="1" /></noscript></a><br />
As shown in the output, this process will take some time as DRaaS will need to first connect to the DRaaS Content Library to import both the SRM/VR Virtual Appliance into your SDDC and then deploy and configure the appliances. You can use the VMC Console to monitor the progress, but we can also use the Get-DRaas function to do so which gives us more granular information about what is happening.</p>
<p><a href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?ssl=1" data-slb-active="1" data-slb-asset="626029494" data-slb-internal="0" data-slb-group="165204"><img data-attachment-id="165217" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-6" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?fit=2546%2C690&amp;ssl=1" data-orig-size="2546,690" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-6" data-image-description data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?fit=300%2C81&amp;ssl=1" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?fit=702%2C191&amp;ssl=1" class="alignnone size-large wp-image-165217 jetpack-lazy-image" src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?resize=702%2C191&#038;ssl=1" alt width="702" height="191" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?resize=1024%2C278&amp;ssl=1 1024w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?resize=300%2C81&amp;ssl=1 300w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?resize=768%2C208&amp;ssl=1 768w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?w=1404&amp;ssl=1 1404w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?w=2106&amp;ssl=1 2106w" data-lazy-sizes="(max-width: 702px) 100vw, 702px" data-lazy-src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?resize=702%2C191&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="165217" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-6" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?fit=2546%2C690&amp;ssl=1" data-orig-size="2546,690" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-6" data-image-description="" data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?fit=300%2C81&amp;ssl=1" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?fit=702%2C191&amp;ssl=1" class="alignnone size-large wp-image-165217" src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?resize=702%2C191&#038;ssl=1" alt="" width="702" height="191" srcset="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?resize=1024%2C278&amp;ssl=1 1024w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?resize=300%2C81&amp;ssl=1 300w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?resize=768%2C208&amp;ssl=1 768w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?w=1404&amp;ssl=1 1404w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-6.png?w=2106&amp;ssl=1 2106w" sizes="(max-width: 702px) 100vw, 702px" data-recalc-dims="1" /></noscript></a><br />
Simply re-run the Get-DRaas function and we can now see some useful information about the overall DRaaS state as well as the individual status for both the SRM and VR Nodes.</p>
<p><a href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?ssl=1" data-slb-active="1" data-slb-asset="611369585" data-slb-internal="0" data-slb-group="165204"><img data-attachment-id="165216" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-5" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?fit=1504%2C578&amp;ssl=1" data-orig-size="1504,578" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-5" data-image-description data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?fit=300%2C115&amp;ssl=1" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?fit=702%2C270&amp;ssl=1" class="alignnone size-large wp-image-165216 jetpack-lazy-image" src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?resize=702%2C270&#038;ssl=1" alt width="702" height="270" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?resize=1024%2C394&amp;ssl=1 1024w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?resize=300%2C115&amp;ssl=1 300w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?resize=768%2C295&amp;ssl=1 768w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?w=1504&amp;ssl=1 1504w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?w=1404&amp;ssl=1 1404w" data-lazy-sizes="(max-width: 702px) 100vw, 702px" data-lazy-src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?resize=702%2C270&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="165216" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-5" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?fit=1504%2C578&amp;ssl=1" data-orig-size="1504,578" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-5" data-image-description="" data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?fit=300%2C115&amp;ssl=1" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?fit=702%2C270&amp;ssl=1" class="alignnone size-large wp-image-165216" src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?resize=702%2C270&#038;ssl=1" alt="" width="702" height="270" srcset="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?resize=1024%2C394&amp;ssl=1 1024w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?resize=300%2C115&amp;ssl=1 300w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?resize=768%2C295&amp;ssl=1 768w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?w=1504&amp;ssl=1 1504w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-5.png?w=1404&amp;ssl=1 1404w" sizes="(max-width: 702px) 100vw, 702px" data-recalc-dims="1" /></noscript></a><br />
To determine when the deployment has completed, you will want to ensure that the DRaaSState is set to ACTIVATED and both the SRM and VR Node State have the READ value. In additon, you can also use this information to create Edge Firewall rules and retrieve the DRaaS URL for setting up SRM.</p>
<p><a href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?ssl=1" data-slb-active="1" data-slb-asset="1666039592" data-slb-internal="0" data-slb-group="165204"><img data-attachment-id="165218" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-7" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?fit=1378%2C658&amp;ssl=1" data-orig-size="1378,658" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-7" data-image-description data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?fit=300%2C143&amp;ssl=1" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?fit=702%2C335&amp;ssl=1" class="alignnone size-large wp-image-165218 jetpack-lazy-image" src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?resize=702%2C335&#038;ssl=1" alt width="702" height="335" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?resize=1024%2C489&amp;ssl=1 1024w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?resize=300%2C143&amp;ssl=1 300w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?resize=768%2C367&amp;ssl=1 768w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?w=1378&amp;ssl=1 1378w" data-lazy-sizes="(max-width: 702px) 100vw, 702px" data-lazy-src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?resize=702%2C335&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="165218" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-7" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?fit=1378%2C658&amp;ssl=1" data-orig-size="1378,658" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-7" data-image-description="" data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?fit=300%2C143&amp;ssl=1" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?fit=702%2C335&amp;ssl=1" class="alignnone size-large wp-image-165218" src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?resize=702%2C335&#038;ssl=1" alt="" width="702" height="335" srcset="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?resize=1024%2C489&amp;ssl=1 1024w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?resize=300%2C143&amp;ssl=1 300w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?resize=768%2C367&amp;ssl=1 768w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-7.png?w=1378&amp;ssl=1 1378w" sizes="(max-width: 702px) 100vw, 702px" data-recalc-dims="1" /></noscript></a><br />
<strong>Step 7</strong> - If you need to deactivate DRaaS for your SDDC, you simply use the Set-DRaas function but now specifying -Deactivate flag by running the following command:</p>
<p class="terminal">Set-DRaaS -Deactivate</p>
<p><a href="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?ssl=1" data-slb-active="1" data-slb-asset="421559348" data-slb-internal="0" data-slb-group="165204"><img data-attachment-id="165219" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-8" data-orig-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?fit=2688%2C216&amp;ssl=1" data-orig-size="2688,216" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-8" data-image-description data-medium-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?fit=300%2C24&amp;ssl=1" data-large-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?fit=702%2C56&amp;ssl=1" class="alignnone size-large wp-image-165219 jetpack-lazy-image" src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?resize=702%2C56&#038;ssl=1" alt width="702" height="56" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?resize=1024%2C82&amp;ssl=1 1024w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?resize=300%2C24&amp;ssl=1 300w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?resize=768%2C62&amp;ssl=1 768w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?w=1404&amp;ssl=1 1404w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?w=2106&amp;ssl=1 2106w" data-lazy-sizes="(max-width: 702px) 100vw, 702px" data-lazy-src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?resize=702%2C56&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="165219" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-8" data-orig-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?fit=2688%2C216&amp;ssl=1" data-orig-size="2688,216" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-8" data-image-description="" data-medium-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?fit=300%2C24&amp;ssl=1" data-large-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?fit=702%2C56&amp;ssl=1" class="alignnone size-large wp-image-165219" src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?resize=702%2C56&#038;ssl=1" alt="" width="702" height="56" srcset="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?resize=1024%2C82&amp;ssl=1 1024w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?resize=300%2C24&amp;ssl=1 300w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?resize=768%2C62&amp;ssl=1 768w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?w=1404&amp;ssl=1 1404w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-8.png?w=2106&amp;ssl=1 2106w" sizes="(max-width: 702px) 100vw, 702px" data-recalc-dims="1" /></noscript></a><br />
Similar to activate, we can also use the Get-DRaas function to monitor the progress of the deactivation.</p>
<p><a href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?ssl=1" data-slb-active="1" data-slb-asset="806520825" data-slb-internal="0" data-slb-group="165204"><img data-attachment-id="165220" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-9" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?fit=1364%2C568&amp;ssl=1" data-orig-size="1364,568" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-9" data-image-description data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?fit=300%2C125&amp;ssl=1" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?fit=702%2C292&amp;ssl=1" class="alignnone size-large wp-image-165220 jetpack-lazy-image" src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?resize=702%2C292&#038;ssl=1" alt width="702" height="292" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?resize=1024%2C426&amp;ssl=1 1024w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?resize=300%2C125&amp;ssl=1 300w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?resize=768%2C320&amp;ssl=1 768w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?w=1364&amp;ssl=1 1364w" data-lazy-sizes="(max-width: 702px) 100vw, 702px" data-lazy-src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?resize=702%2C292&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="165220" data-permalink="https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html/automating-vmware-site-recovery-draas-on-vmc-9" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?fit=1364%2C568&amp;ssl=1" data-orig-size="1364,568" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="automating-vmware-site-recovery-draas-on-vmc-9" data-image-description="" data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?fit=300%2C125&amp;ssl=1" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?fit=702%2C292&amp;ssl=1" class="alignnone size-large wp-image-165220" src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?resize=702%2C292&#038;ssl=1" alt="" width="702" height="292" srcset="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?resize=1024%2C426&amp;ssl=1 1024w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?resize=300%2C125&amp;ssl=1 300w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?resize=768%2C320&amp;ssl=1 768w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2019/05/automating-vmware-site-recovery-draas-on-vmc-9.png?w=1364&amp;ssl=1 1364w" sizes="(max-width: 702px) 100vw, 702px" data-recalc-dims="1" /></noscript></a></p>
<div class="wp_rp_wrap  wp_rp_vertical_m" id="wp_rp_first"><div class="wp_rp_content"><h3 class="related_post_title">More from my site</h3><ul class="related_post wp_rp"><li data-position="0" data-poid="in-158519" data-post-type="none"><a href="https://www.virtuallyghetto.com/2017/07/quick-tip-locating-srm-placeholder-vms-using-the-vsphere-api.html" class="wp_rp_title">Quick Tip &#8211; Locating SRM Placeholder VMs using the vSphere API</a></li><li data-position="1" data-poid="in-10865" data-post-type="none"><a href="https://www.virtuallyghetto.com/2014/10/automating-the-silent-installation-of-site-recovery-manager-5-8-wembedded-vpostgres-db.html" class="wp_rp_title">Automating the silent installation of Site Recovery Manager 5.8 w/Embedded vPostgres DB</a></li><li data-position="2" data-poid="in-15925" data-post-type="none"><a href="https://www.virtuallyghetto.com/2015/11/automating-the-silent-installation-of-site-recovery-manager-6-06-1-wembedded-vpostgres-db.html" class="wp_rp_title">Automating the silent installation of Site Recovery Manager 6.0/6.1 w/Embedded vPostgres DB</a></li><li data-position="3" data-poid="in-163680" data-post-type="none"><a href="https://www.virtuallyghetto.com/2019/01/new-vmc-api-to-rename-sddc.html" class="wp_rp_title">New VMC API to rename SDDC</a></li><li data-position="4" data-poid="in-161983" data-post-type="none"><a href="https://www.virtuallyghetto.com/2018/07/automation-with-the-vmware-cloud-services-portal-csp.html" class="wp_rp_title">Automation with the VMware Cloud Services Platform (CSP)</a></li></ul></div></div>
<div class="ssba-modern-2 ssba ssbp-wrap left ssbp--theme-1"><div style="text-align:left"><span class="ssba-share-text">Share this...</span><br /><ul class="ssbp-list"><li class="ssbp-li--twitter"><a data-site="" class="ssba_twitter_share ssbp-twitter ssbp-btn" href="https://twitter.com/share?url=https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html&amp;text=Automating%20VMware%20Site%20Recovery%20%28DRaaS%29%20with%20VMC%20" target=&quot;_blank&quot;><div title="Twitter" class="ssbp-text">Twitter</div></a></li><li class="ssbp-li--facebook"><a data-site="" class="ssba_facebook_share ssbp-facebook ssbp-btn" href="https://www.facebook.com/sharer.php?u=https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html" target="_blank"><div title="Facebook" class="ssbp-text">Facebook</div></a></li><li class="ssbp-li--linkedin"><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link ssbp-linkedin ssbp-btn" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html" target=&quot;_blank&quot;><div title="Linkedin" class="ssbp-text">Linkedin</div></a></li><li class="ssbp-li--reddit"><a data-site="reddit" class="ssba_reddit_share ssbp-reddit ssbp-btn" href="https://reddit.com/submit?url=https://www.virtuallyghetto.com/2019/05/automating-vmware-site-recovery-draas-with-vmc.html&amp;title=Automating VMware Site Recovery (DRaaS) with VMC" target=&quot;_blank&quot;><div title="Reddit" class="ssbp-text">Reddit</div></a></li><li class="ssbp-li--pinterest"><a data-site='pinterest' class='ssba_pinterest_share ssbp-pinterest ssbp-btn' href='javascript:void((function()%7Bvar%20e=document.createElement(&apos;script&apos;);e.setAttribute(&apos;type&apos;,&apos;text/javascript&apos;);e.setAttribute(&apos;charset&apos;,&apos;UTF-8&apos;);e.setAttribute(&apos;src&apos;,&apos;//assets.pinterest.com/js/pinmarklet.js?r=&apos;+Math.random()*99999999);document.body.appendChild(e)%7D)());'><div title="Pinterest" class="ssbp-text">Pinterest</div></a></li></ul></div></div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://www.virtuallyghetto.com/category/automation" rel="category tag">Automation</a>, <a href="https://www.virtuallyghetto.com/category/powercli" rel="category tag">PowerCLI</a>, <a href="https://www.virtuallyghetto.com/category/vmware-cloud-on-aws" rel="category tag">VMware Cloud on AWS</a></span> <span class="entry-tags">Tagged With: <a href="https://www.virtuallyghetto.com/tag/draas" rel="tag">DRaaS</a>, <a href="https://www.virtuallyghetto.com/tag/site-recovery-manager" rel="tag">site recovery manager</a>, <a href="https://www.virtuallyghetto.com/tag/srm-2" rel="tag">srm</a>, <a href="https://www.virtuallyghetto.com/tag/vmc" rel="tag">VMC</a>, <a href="https://www.virtuallyghetto.com/tag/vmware-cloud-on-aws" rel="tag">VMware Cloud on AWS</a>, <a href="https://www.virtuallyghetto.com/tag/vmware-site-recovery" rel="tag">VMware Site Recovery</a></span></p></footer></article><h2 class="screen-reader-text">Reader Interactions</h2>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Thanks for the comment! <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/05/automating-vmware-site-recovery-draas-with-vmc.html#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=67295360&#038;postid=165204&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=retro&#038;greeting=Thanks+for+the+comment%21&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=transparent&#038;lang=en_US&#038;jetpack_version=7.3.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;sig=0fd3ff99d705c735708ed250f10b73c4bad22284#parent=https%3A%2F%2Fwww.virtuallyghetto.com%2F2019%2F05%2Fautomating-vmware-site-recovery-draas-with-vmc.html" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = true;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="search-7" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="https://www.virtuallyghetto.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-5ced6c7f7c0952.24774374">Search this website</label><input class="search-form-input" type="search" itemprop="query-input" name="s" id="searchform-5ced6c7f7c0952.24774374" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta itemprop="target" content="https://www.virtuallyghetto.com/?s={s}"></form></div></section>
<section id="user-profile-9" class="widget user-profile"><div class="widget-wrap"><h3 class="widgettitle widget-title">Author</h3>
<p><span class="alignleft"><img class="avatar avatar-125 photo jetpack-lazy-image" width="64" height="64" src="https://www.virtuallyghetto.com/wp-content/uploads/2017/01/292c324.jpg" data-lazy-src="https://www.virtuallyghetto.com/wp-content/uploads/2017/01/292c324.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="avatar avatar-125 photo" width="64" height="64" src="https://www.virtuallyghetto.com/wp-content/uploads/2017/01/292c324.jpg"/></noscript></span>William Lam is a Staff Solutions Architect working in the VMware Cloud on AWS team within the Cloud Platform Business Unit (CPBU) at VMware. He focuses on Automation, Integration and Operation of the VMware Software Defined Datacenter (SDDC).</p>
</div></section>
<section id="simple-social-icons-4" class="widget simple-social-icons"><div class="widget-wrap"><ul class="aligncenter"><li class="ssi-github"><a href="https://github.com/lamw" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-github" aria-labelledby="social-github-4"><title id="social-github-4">GitHub</title><use xlink:href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-github"></use></svg></a></li><li class="ssi-gplus"><a href="https://plus.google.com/114142893306148938477" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-gplus" aria-labelledby="social-gplus-4"><title id="social-gplus-4">Google+</title><use xlink:href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-gplus"></use></svg></a></li><li class="ssi-linkedin"><a href="https://www.linkedin.com/in/lamwilliam/" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-linkedin" aria-labelledby="social-linkedin-4"><title id="social-linkedin-4">LinkedIn</title><use xlink:href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-linkedin"></use></svg></a></li><li class="ssi-rss"><a href="https://www.virtuallyghetto.com/rss" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-rss" aria-labelledby="social-rss-4"><title id="social-rss-4">RSS</title><use xlink:href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-rss"></use></svg></a></li><li class="ssi-twitter"><a href="https://twitter.com/lamw" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-twitter" aria-labelledby="social-twitter-4"><title id="social-twitter-4">Twitter</title><use xlink:href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li></ul></div></section>
<section id="bsa-6" class="widget widget_bsa"><div class="widget-wrap"><h3 class="widgettitle widget-title">Sponsors</h3>

<div id="bsap_1282588" class="bsarocks bsap_6d274f0434e88e8f84574d74902bc1c4"></div>

</div></section>
<section id="eu_cookie_law_widget-2" class="widget widget_eu_cookie_law_widget"><div class="widget-wrap"><div class="hide-on-button negative" data-hide-timeout="30" data-consent-expiration="180" id="eu-cookie-law">
<form method="post">
<input type="submit" value="Close and accept" class="accept" />
</form>
Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
<a href="https://www.virtuallyghetto.com/privacy-policy">
Cookie Policy	</a>
</div>
</div></section>
</aside></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"></div></footer></div> <div style="display:none">
<div class="grofile-hash-map-b9d29da4e111863744d8421dc0801219">
</div>
</div>
<style type="text/css" media="screen"> #simple-social-icons-4 ul li a, #simple-social-icons-4 ul li a:hover, #simple-social-icons-4 ul li a:focus { background-color: #000000 !important; border-radius: 6px; color: #ffffff !important; border: 0px #ffffff solid !important; font-size: 18px; padding: 9px; }  #simple-social-icons-4 ul li a:hover, #simple-social-icons-4 ul li a:focus { background-color: #830101 !important; border-color: #ffffff !important; color: #ffffff !important; }  #simple-social-icons-4 ul li a:focus { outline: 1px dotted #830101 !important; }</style><link rel='stylesheet' id='simple-share-buttons-adder-ssba-css' href='https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=5.2.1' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
.ssba img
								{border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								.ssba-classic-2 .ssbp-text {
									display: none!important;
								}
					.ssbp-list li a {height: 32px!important; width: 32px!important; 
					}
					.ssbp-list li a:hover {
					}
						
					.ssbp-list li a::before {line-height: 32px!important;; font-size: 24px;}
					.ssbp-list li a:hover::before {}
					.ssbp-list li {
					margin-left: 12px!important;
					}
					
					.ssba-share-text {
					font-size: 14px;  font-weight: normal; font-family: inherit;
						}

			   #ssba-bar-2 .ssbp-bar-list {
					max-width: 48px!important;;
			   }
			   #ssba-bar-2 .ssbp-bar-list li a {height: 48px!important; width: 48px!important; 
				}
				#ssba-bar-2 .ssbp-bar-list li a:hover {
				}
					
				#ssba-bar-2 .ssbp-bar-list li a::before {line-height: 48px!important;; font-size: 18px;}
				#ssba-bar-2 .ssbp-bar-list li a:hover::before {}
				#ssba-bar-2 .ssbp-bar-list li {
				margin: 0px 0!important;
				}@media only screen and ( max-width: 750px ) {
				#ssba-bar-2 {
				display: block;
				}
			}
@font-face {
				font-family: 'ssbp';
				src:url('https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?xj3ol1');
				src:url('https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?#iefixxj3ol1') format('embedded-opentype'),
					url('https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.woff?xj3ol1') format('woff'),
					url('https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.ttf?xj3ol1') format('truetype'),
					url('https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.svg?xj3ol1#ssbp') format('svg');
				font-weight: normal;
				font-style: normal;

				/* Better Font Rendering =========== */
				-webkit-font-smoothing: antialiased;
				-moz-osx-font-smoothing: grayscale;
			}
</style>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20190201'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201922'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.js?ver=5.2.1'></script>
<script type='text/javascript'>
Main.boot( [] );
</script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Mayaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-includes/js/comment-reply.min.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=2.10.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=2.10.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var genesis_responsive_menu = {"mainMenu":"Menu","menuIconClass":"dashicons-before dashicons-menu","subMenu":"Submenu","subMenuIconClass":"dashicons-before dashicons-arrow-down-alt2","menuClasses":{"combine":[".nav-primary"],"others":[]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/themes/genesis-sample/js/responsive-menus.min.js?ver=2.6.0'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/themes/genesis-sample/js/genesis-sample.js?ver=2.6.0'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js?ver=20180522'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/lazy-images/js/lazy-images.min.js?ver=7.3.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=7.3.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-includes/js/wp-embed.min.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.virtuallyghetto.com\/wp-admin\/admin-ajax.php","nonce":"8d70b47433","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.virtuallyghetto.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.virtuallyghetto.com%2F2019%2F05%2Fautomating-vmware-site-recovery-draas-with-vmc.html","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20190102'></script>
<script async="async" type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.2'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/client/js/prod/lib.core.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/client/js/prod/lib.view.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/themes/baseline/js/prod/client.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/themes/default/js/prod/client.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/template-tags/item/js/prod/tag.item.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/template-tags/ui/js/prod/tag.ui.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/content-handlers/image/js/prod/handler.image.js?ver=2.7.1'></script>
<script type="text/javascript" id="slb_footer">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</script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=67295360&postid=165204&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=retro&greeting=Thanks+for+the+comment%21&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=7.3.1&show_cookie_consent=10&has_cookie_consent=0&sig=0fd3ff99d705c735708ed250f10b73c4bad22284#parent=https%3A%2F%2Fwww.virtuallyghetto.com%2F2019%2F05%2Fautomating-vmware-site-recovery-draas-with-vmc.html" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=67295360&postid=165204&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=retro&greeting=Thanks+for+the+comment%21&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=7.3.1&show_cookie_consent=10&has_cookie_consent=0&sig=0fd3ff99d705c735708ed250f10b73c4bad22284#parent=https%3A%2F%2Fwww.virtuallyghetto.com%2F2019%2F05%2Fautomating-vmware-site-recovery-draas-with-vmc.html";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script type='text/javascript' src='https://stats.wp.com/e-201922.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.3.1',blog:'67295360',post:'165204',tz:'-7',srv:'www.virtuallyghetto.com'} ]);
	_stq.push([ 'clickTrackerInit', '67295360', '165204' ]);
</script>
</body></html>
