<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Custom Virtual Machine Class Types with vSphere with Tanzu</title>
<script>(function(d, s, id){
				 var js, fjs = d.getElementsByTagName(s)[0];
				 if (d.getElementById(id)) {return;}
				 js = d.createElement(s); js.id = id;
				 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
				 fjs.parentNode.insertBefore(js, fjs);
			   }(document, 'script', 'facebook-jssdk'));</script><link rel='dns-prefetch' href='//ws.sharethis.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel="alternate" type="application/rss+xml" title="virtuallyGhetto &raquo; Feed" href="https://www.virtuallyghetto.com/feed" />
<link rel="alternate" type="application/rss+xml" title="virtuallyGhetto &raquo; Comments Feed" href="https://www.virtuallyghetto.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="virtuallyGhetto &raquo; Custom Virtual Machine Class Types with vSphere with Tanzu Comments Feed" href="https://www.virtuallyghetto.com/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html/feed" />
<link rel="canonical" href="https://www.virtuallyghetto.com/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.virtuallyghetto.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='crayon-css' href='https://www.virtuallyghetto.com/wp-content/plugins/crayon-syntax-highlighter/css/min/crayon.min.css?ver=_2.7.2_beta' type='text/css' media='all' />
<link rel='stylesheet' id='crayon-theme-tomorrow-night-css' href='https://www.virtuallyghetto.com/wp-content/plugins/crayon-syntax-highlighter/themes/tomorrow-night/tomorrow-night.css?ver=_2.7.2_beta' type='text/css' media='all' />
<link rel='stylesheet' id='crayon-font-monaco-css' href='https://www.virtuallyghetto.com/wp-content/plugins/crayon-syntax-highlighter/fonts/monaco.css?ver=_2.7.2_beta' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-sample-css' href='https://www.virtuallyghetto.com/wp-content/themes/genesis-sample/style.css?ver=2.6.0' type='text/css' media='all' />
<style id='genesis-sample-inline-css' type='text/css'>


		a,
		.entry-title a:focus,
		.entry-title a:hover,
		.genesis-nav-menu a:focus,
		.genesis-nav-menu a:hover,
		.genesis-nav-menu .current-menu-item > a,
		.genesis-nav-menu .sub-menu .current-menu-item > a:focus,
		.genesis-nav-menu .sub-menu .current-menu-item > a:hover,
		.menu-toggle:focus,
		.menu-toggle:hover,
		.sub-menu-toggle:focus,
		.sub-menu-toggle:hover {
			color: #830101;
		}

		

		button:focus,
		button:hover,
		input[type="button"]:focus,
		input[type="button"]:hover,
		input[type="reset"]:focus,
		input[type="reset"]:hover,
		input[type="submit"]:focus,
		input[type="submit"]:hover,
		input[type="reset"]:focus,
		input[type="reset"]:hover,
		input[type="submit"]:focus,
		input[type="submit"]:hover,
		.button:focus,
		.button:hover,
		.genesis-nav-menu > .menu-highlight > a:hover,
		.genesis-nav-menu > .menu-highlight > a:focus,
		.genesis-nav-menu > .menu-highlight.current-menu-item > a {
			background-color: #830101;
			color: #ffffff;
		}
		
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.virtuallyghetto.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='easy_author_image-css' href='https://www.virtuallyghetto.com/wp-content/plugins/easy-author-image/css/easy-author-image.css?ver=5.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='eeb-css-frontend-css' href='https://www.virtuallyghetto.com/wp-content/plugins/email-encoder-bundle/core/includes/assets/css/style.css?ver=201012-130506' type='text/css' media='all' />
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=5.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-sample-fonts-css' href='//fonts.googleapis.com/css?family=Source+Sans+Pro%3A400%2C400i%2C600%2C700&#038;ver=2.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://www.virtuallyghetto.com/wp-includes/css/dashicons.min.css?ver=5.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css' href='https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/css/style.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css' href='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='easy_table_style-css' href='https://www.virtuallyghetto.com/wp-content/plugins/easy-table/themes/cuscosky/style.css?ver=1.8' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.0.2' type='text/css' media='all' />
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' id='crayon_js-js-extra'>
/* <![CDATA[ */
var CrayonSyntaxSettings = {"version":"_2.7.2_beta","is_admin":"0","ajaxurl":"https:\/\/www.virtuallyghetto.com\/wp-admin\/admin-ajax.php","prefix":"crayon-","setting":"crayon-setting","selected":"crayon-setting-selected","changed":"crayon-setting-changed","special":"crayon-setting-special","orig_value":"data-orig-value","debug":""};
var CrayonSyntaxStrings = {"copy":"Press %s to Copy, %s to Paste","minimize":"Click To Expand Code"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/crayon-syntax-highlighter/js/min/crayon.min.js?ver=_2.7.2_beta' id='crayon_js-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/email-encoder-bundle/core/includes/assets/js/custom.js?ver=201012-130506' id='eeb-js-frontend-js'></script>
<script id='st_insights_js' type='text/javascript' src='https://ws.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare' id='ssba-sharethis-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21' id='svg-x-use-js'></script>
<link rel="https://api.w.org/" href="https://www.virtuallyghetto.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.virtuallyghetto.com/wp-json/wp/v2/posts/170248" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.virtuallyghetto.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="https://www.virtuallyghetto.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.virtuallyghetto.com%2F2020%2F10%2Fcustom-virtual-machine-class-types-with-vsphere-with-tanzu.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.virtuallyghetto.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.virtuallyghetto.com%2F2020%2F10%2Fcustom-virtual-machine-class-types-with-vsphere-with-tanzu.html&#038;format=xml" />

<script type="text/javascript">
        (function(){
          var bsa = document.createElement('script');
              bsa.type= 'text/javascript';
              bsa.async = true;
              bsa.src='//s3.buysellads.com/ac/bsa.js';
          (document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(bsa);
        })();
        </script>

<script type="text/javascript">
	window._wp_rp_static_base_url = 'https://wprp.zemanta.com/static/';
	window._wp_rp_wp_ajax_url = "https://www.virtuallyghetto.com/wp-admin/admin-ajax.php";
	window._wp_rp_plugin_version = '3.6.4';
	window._wp_rp_post_id = '170248';
	window._wp_rp_num_rel_posts = '5';
	window._wp_rp_thumbnails = false;
	window._wp_rp_post_title = 'Custom+Virtual+Machine+Class+Types+with+vSphere+with+Tanzu';
	window._wp_rp_post_tags = ['vsphere+with+tanzu', 'kubernetes', 'vmware+tanzu', 'set', 'resourc', 'class', 'control', 'sampl', 'vsphere', 'servic', 'custom', 'grid', 'memori', 'virtual', 'machin', 'network', 'plane', 'pod'];
	window._wp_rp_promoted_content = true;
</script>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>

<meta property="og:type" content="article" />
<meta property="og:title" content="Custom Virtual Machine Class Types with vSphere with Tanzu" />
<meta property="og:url" content="https://www.virtuallyghetto.com/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html" />
<meta property="og:description" content="When you deploy a Tanzu Kubernetes Grid (TKG) Cluster using the integrated TKG Service in vSphere with Tanzu, you can specify a Virtual Machine Class Type which determines the amount of CPU and Mem…" />
<meta property="article:published_time" content="2020-10-30T21:09:27+00:00" />
<meta property="article:modified_time" content="2020-10-30T21:09:27+00:00" />
<meta property="og:site_name" content="virtuallyGhetto" />
<meta property="og:image" content="https://www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png" />
<meta property="og:image:width" content="712" />
<meta property="og:image:height" content="461" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Custom Virtual Machine Class Types with vSphere with Tanzu" />
<meta name="twitter:image" content="https://www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<link rel="icon" href="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2016/10/vghetto.png?fit=240%2C240&#038;ssl=1" />
<style type="text/css" id="wp-custom-css">
				.terminal {
	border: 1px grey dashed;
	padding: 10px;
	background-color: whiteSmoke;
	color: black;
	font-family: "Lucida Console", Monaco, monospace;
	font-size: small;
}			</style>
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-170248 single-format-standard header-full-width content-sidebar genesis-breadcrumbs-visible genesis-footer-widgets-hidden" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://www.virtuallyghetto.com/">virtuallyGhetto</a></p></div><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary"><div class="wrap"><ul id="menu-main" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-510" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-510"><a href="https://www.virtuallyghetto.com/about" itemprop="url"><span itemprop="name">About</span></a></li>
<li id="menu-item-161462" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-161462"><a href="https://www.virtuallyghetto.com/privacy-policy" itemprop="url"><span itemprop="name">Privacy</span></a></li>
<li id="menu-item-165250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-165250"><a href="https://www.virtuallyghetto.com/vmware-cloud-on-aws" itemprop="url"><span itemprop="name">VMware Cloud</span></a></li>
<li id="menu-item-165282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-165282"><a href="https://www.virtuallyghetto.com/home-lab" itemprop="url"><span itemprop="name">Home Lab</span></a></li>
<li id="menu-item-450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-450"><a href="https://www.virtuallyghetto.com/nested-virtualization" itemprop="url"><span itemprop="name">Nested Virtualization</span></a></li>
<li id="menu-item-760" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-760"><a href="#" itemprop="url"><span itemprop="name">Automation</span></a>
<ul class="sub-menu">
<li id="menu-item-591" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-591"><a href="https://www.virtuallyghetto.com/vmware-kickstart" itemprop="url"><span itemprop="name">VMware Kickstart</span></a></li>
<li id="menu-item-593" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-593"><a href="https://www.virtuallyghetto.com/kickstart" itemprop="url"><span itemprop="name">VMware API/SDK/CLI</span></a></li>
<li id="menu-item-592" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-592"><a href="https://www.virtuallyghetto.com/vmware-vmavima" itemprop="url"><span itemprop="name">VMware vMA/VIMA</span></a></li>
<li id="menu-item-13682" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13682"><a href="https://www.virtuallyghetto.com/ovf" itemprop="url"><span itemprop="name">VMware OVF / OVFTOOL</span></a></li>
</ul>
</li>
<li id="menu-item-448" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-448"><a href="https://www.virtuallyghetto.com/apple" itemprop="url"><span itemprop="name">Apple Mac</span></a></li>
<li id="menu-item-449" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-449"><a href="https://www.virtuallyghetto.com/vcsa" itemprop="url"><span itemprop="name">VCSA</span></a></li>
<li id="menu-item-10631" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10631"><a href="https://www.virtuallyghetto.com/vsan" itemprop="url"><span itemprop="name">VSAN</span></a></li>
</ul></div></nav></div></header><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://www.virtuallyghetto.com/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Home</span></a><meta itemprop="position" content="1"></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://www.virtuallyghetto.com/category/kubernetes" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Kubernetes</span></a><meta itemprop="position" content="2"></span> <span aria-label="breadcrumb separator">/</span> Custom Virtual Machine Class Types with vSphere with Tanzu</div><article class="post-170248 post type-post status-publish format-standard category-kubernetes category-vmware-tanzu tag-vsphere-with-tanzu entry" aria-label="Custom Virtual Machine Class Types with vSphere with Tanzu" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Custom Virtual Machine Class Types with vSphere with Tanzu</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2020-10-30T14:09:27-07:00">10/30/2020</time> by <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://www.virtuallyghetto.com/author/lamw" class="entry-author-link" rel="author" itemprop="url"><span class="entry-author-name" itemprop="name">William Lam</span></a></span> <span class="entry-comments-link"><a href="https://www.virtuallyghetto.com/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text"><p>When you deploy a Tanzu Kubernetes Grid (TKG) Cluster using the integrated TKG Service in vSphere with Tanzu, you can specify a <a href="https://docs.vmware.com/en/VMware-vSphere/7.0/vmware-vsphere-with-tanzu/GUID-7351EEFF-4EF0-468F-A19B-6CEA40983D3D.html" target="_blank" rel="noopener noreferrer">Virtual Machine Class Type</a> which determines the amount of CPU and Memory resources that are allocated for both the Control Plane and/or Worker Node VMs for your TKG Cluster.</p>
<p>Here is a sample YAML specification that uses the <strong>best-effort-xsmall</strong> VM class type for both Control Plane and Worker Node, but you can certainly override and choose different classes based on your requirements.</p>
<div id="crayon-5f9c82e78980c614634447" class="crayon-syntax crayon-theme-tomorrow-night crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Toggle Line Numbers"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Toggle Plain Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Open Code In New Window"><div class="crayon-button-icon"></div></div></div></div>
<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
apiVersion: run.tanzu.vmware.com/v1alpha1
kind: TanzuKubernetesCluster
metadata:
  name: william-tkc-01
  namespace: primp-industries
spec:
  distribution:
    version: v1.17.8+vmware.1-tkg.1.5417466
  settings:
    network:
      cni:
        name: antrea
      pods:
        cidrBlocks:
        - 193.0.2.0/16
      serviceDomain: managedcluster.local
      services:
        cidrBlocks:
        - 195.51.100.0/12
  topology:
    controlPlane:
      class: best-effort-xsmall
      count: 1
      storageClass: vsan-default-storage-policy
    workers:
      class: best-effort-xsmall
      count: 3
      storageClass: vsan-default-storage-policy</textarea></div>
<div class="crayon-main" style="">
<table class="crayon-table">
<tr class="crayon-row">
<td class="crayon-nums " data-settings="show">
<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5f9c82e78980c614634447-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78980c614634447-2">2</div><div class="crayon-num" data-line="crayon-5f9c82e78980c614634447-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78980c614634447-4">4</div><div class="crayon-num" data-line="crayon-5f9c82e78980c614634447-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78980c614634447-6">6</div><div class="crayon-num" data-line="crayon-5f9c82e78980c614634447-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78980c614634447-8">8</div><div class="crayon-num" data-line="crayon-5f9c82e78980c614634447-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78980c614634447-10">10</div><div class="crayon-num" data-line="crayon-5f9c82e78980c614634447-11">11</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78980c614634447-12">12</div><div class="crayon-num" data-line="crayon-5f9c82e78980c614634447-13">13</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78980c614634447-14">14</div><div class="crayon-num" data-line="crayon-5f9c82e78980c614634447-15">15</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78980c614634447-16">16</div><div class="crayon-num" data-line="crayon-5f9c82e78980c614634447-17">17</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78980c614634447-18">18</div><div class="crayon-num" data-line="crayon-5f9c82e78980c614634447-19">19</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78980c614634447-20">20</div><div class="crayon-num" data-line="crayon-5f9c82e78980c614634447-21">21</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78980c614634447-22">22</div><div class="crayon-num" data-line="crayon-5f9c82e78980c614634447-23">23</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78980c614634447-24">24</div><div class="crayon-num" data-line="crayon-5f9c82e78980c614634447-25">25</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78980c614634447-26">26</div><div class="crayon-num" data-line="crayon-5f9c82e78980c614634447-27">27</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78980c614634447-28">28</div></div>
</td>
<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5f9c82e78980c614634447-1"><span class="crayon-v">apiVersion</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">run</span><span class="crayon-sy">.</span><span class="crayon-v">tanzu</span><span class="crayon-sy">.</span><span class="crayon-v">vmware</span><span class="crayon-sy">.</span><span class="crayon-v">com</span><span class="crayon-o">/</span><span class="crayon-e">v1alpha1</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78980c614634447-2"><span class="crayon-v">kind</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-e">TanzuKubernetesCluster</span></div><div class="crayon-line" id="crayon-5f9c82e78980c614634447-3"><span class="crayon-v">metadata</span><span class="crayon-o">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78980c614634447-4"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">name</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">william</span><span class="crayon-o">-</span><span class="crayon-v">tkc</span><span class="crayon-o">-</span><span class="crayon-cn">01</span></div><div class="crayon-line" id="crayon-5f9c82e78980c614634447-5"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-t">namespace</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">primp</span><span class="crayon-o">-</span><span class="crayon-e">industries</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78980c614634447-6"><span class="crayon-v">spec</span><span class="crayon-o">:</span></div><div class="crayon-line" id="crayon-5f9c82e78980c614634447-7"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">distribution</span><span class="crayon-o">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78980c614634447-8"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">version</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">v1</span><span class="crayon-sy">.</span><span class="crayon-cn">17.8</span><span class="crayon-o">+</span><span class="crayon-v">vmware</span><span class="crayon-sy">.</span><span class="crayon-cn">1</span><span class="crayon-o">-</span><span class="crayon-v">tkg</span><span class="crayon-sy">.</span><span class="crayon-cn">1.5417466</span></div><div class="crayon-line" id="crayon-5f9c82e78980c614634447-9"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">settings</span><span class="crayon-o">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78980c614634447-10"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">network</span><span class="crayon-o">:</span></div><div class="crayon-line" id="crayon-5f9c82e78980c614634447-11"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">cni</span><span class="crayon-o">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78980c614634447-12"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">name</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-e">antrea</span></div><div class="crayon-line" id="crayon-5f9c82e78980c614634447-13"><span class="crayon-e">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">pods</span><span class="crayon-o">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78980c614634447-14"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">cidrBlocks</span><span class="crayon-o">:</span></div><div class="crayon-line" id="crayon-5f9c82e78980c614634447-15"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">-</span><span class="crayon-h"> </span><span class="crayon-cn">193.0.2.0</span><span class="crayon-o">/</span><span class="crayon-cn">16</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78980c614634447-16"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">serviceDomain</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">managedcluster</span><span class="crayon-sy">.</span><span class="crayon-e">local</span></div><div class="crayon-line" id="crayon-5f9c82e78980c614634447-17"><span class="crayon-e">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">services</span><span class="crayon-o">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78980c614634447-18"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">cidrBlocks</span><span class="crayon-o">:</span></div><div class="crayon-line" id="crayon-5f9c82e78980c614634447-19"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">-</span><span class="crayon-h"> </span><span class="crayon-cn">195.51.100.0</span><span class="crayon-o">/</span><span class="crayon-cn">12</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78980c614634447-20"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">topology</span><span class="crayon-o">:</span></div><div class="crayon-line" id="crayon-5f9c82e78980c614634447-21"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">controlPlane</span><span class="crayon-o">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78980c614634447-22"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-t">class</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">best</span><span class="crayon-o">-</span><span class="crayon-v">effort</span><span class="crayon-o">-</span><span class="crayon-e">xsmall</span></div><div class="crayon-line" id="crayon-5f9c82e78980c614634447-23"><span class="crayon-e">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">count</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">1</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78980c614634447-24"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">storageClass</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">vsan</span><span class="crayon-o">-</span><span class="crayon-st">default</span><span class="crayon-o">-</span><span class="crayon-v">storage</span><span class="crayon-o">-</span><span class="crayon-e">policy</span></div><div class="crayon-line" id="crayon-5f9c82e78980c614634447-25"><span class="crayon-e">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">workers</span><span class="crayon-o">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78980c614634447-26"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-t">class</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">best</span><span class="crayon-o">-</span><span class="crayon-v">effort</span><span class="crayon-o">-</span><span class="crayon-e">xsmall</span></div><div class="crayon-line" id="crayon-5f9c82e78980c614634447-27"><span class="crayon-e">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">count</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">3</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78980c614634447-28"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">storageClass</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">vsan</span><span class="crayon-o">-</span><span class="crayon-st">default</span><span class="crayon-o">-</span><span class="crayon-v">storage</span><span class="crayon-o">-</span><span class="crayon-v">policy</span></div></div></td>
</tr>
</table>
</div>
</div>

<p>Today, the are a total of 16 VM Class types that you can select from, however these are not customizable which is something that has been coming up more recently. The vSphere with Tanzu team is aware of this request and is working on a solution that not only makes customizing CPU and Memory easier but also supporting storage customization. As you can see from the table below, 16GB is only supported configuration today.</p>
<p><a href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?ssl=1" data-slb-active="1" data-slb-asset="53153685" data-slb-internal="0" data-slb-group="170248"><img data-attachment-id="170251" data-permalink="https://www.virtuallyghetto.com/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html/custom-virtual-machine-class-typs-vsphere-with-tanzu-0" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?fit=1662%2C1186&amp;ssl=1" data-orig-size="1662,1186" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="custom-virtual-machine-class-typs-vsphere-with-tanzu-0" data-image-description data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?fit=300%2C214&amp;ssl=1" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?fit=702%2C501&amp;ssl=1" loading="lazy" class="alignnone size-large wp-image-170251 jetpack-lazy-image" src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?resize=702%2C501&#038;ssl=1" alt width="702" height="501" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?resize=1024%2C731&amp;ssl=1 1024w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?resize=300%2C214&amp;ssl=1 300w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?resize=768%2C548&amp;ssl=1 768w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?resize=1536%2C1096&amp;ssl=1 1536w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?w=1662&amp;ssl=1 1662w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?w=1404&amp;ssl=1 1404w" data-lazy-sizes="(max-width: 702px) 100vw, 702px" data-lazy-src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?resize=702%2C501&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="170251" data-permalink="https://www.virtuallyghetto.com/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html/custom-virtual-machine-class-typs-vsphere-with-tanzu-0" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?fit=1662%2C1186&amp;ssl=1" data-orig-size="1662,1186" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="custom-virtual-machine-class-typs-vsphere-with-tanzu-0" data-image-description="" data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?fit=300%2C214&amp;ssl=1" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?fit=702%2C501&amp;ssl=1" loading="lazy" class="alignnone size-large wp-image-170251" src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?resize=702%2C501&#038;ssl=1" alt="" width="702" height="501" srcset="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?resize=1024%2C731&amp;ssl=1 1024w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?resize=300%2C214&amp;ssl=1 300w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?resize=768%2C548&amp;ssl=1 768w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?resize=1536%2C1096&amp;ssl=1 1536w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?w=1662&amp;ssl=1 1662w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png?w=1404&amp;ssl=1 1404w" sizes="(max-width: 702px) 100vw, 702px" data-recalc-dims="1" /></noscript></a><br />
In the mean time, if you need a supported path for customizing your TKG Guest Clusters, one option is to use the <a href="https://docs.vmware.com/en/VMware-Tanzu-Kubernetes-Grid/1.2/vmware-tanzu-kubernetes-grid-12/GUID-mgmt-clusters-vsphere-cli.html" target="_blank" rel="noopener noreferrer">TKG Standalone / MultiCloud CLI</a>, which can be used with a vSphere with Tanzu Cluster. You will need to deploy an additional TKG Management Cluster (basically a few VMs), but once you have that, you can override CPU, Memory and Storage of both the Control Plane and Worker Nodes using the following environment variables:</p>
<ul>
<li><strong>VSPHERE_WORKER_NUM_CPUS</strong></li>
<li><strong>VSPHERE_WORKER_MEM_MIB</strong></li>
<li><strong>VSPHERE_WORKER_DISK_GIB</strong></li>
<li><strong>VSPHERE_CONTROL_PLANE_NUM_CPUS</strong></li>
<li><strong>VSPHERE_CONTROL_PLANE_MEM_MIB</strong></li>
<li><strong>VSPHERE_CONTROL_PLANE_DISK_GIB</strong></li>
</ul>
<p>If you are interested, the easiest way to get started is by using my <a href="https://www.virtuallyghetto.com/2020/10/tanzu-kubernetes-grid-tkg-demo-appliance-1-2-0.html" target="_blank" rel="noopener noreferrer">TKG Demo Appliance Fling</a> which was just recently updated to the latest TKG 1.2 release which has support for K8s v1.19 which is currently not available on vSphere with Tanzu.</p>
<p>Now, you might ask, would it be possible to create your own custom VM class types using vSphere with Tanzu? Well .... keep reading to find out 🙂</p>
<p><span style="color: #ff0000;"><strong>Disclaimer:</strong></span> This is not officially supported by VMware, use at your own risk. These custom changes can potentially impact upgrades or automatically be reverted upon the next update or upgrade. You have been warned.</p>
<p><span id="more-170248"></span></p>
<p><strong>Step 1</strong> - SSH to your vCenter Server and run the following command to retrieve the root password so we can login to the Supervisor VM VIP</p>
<p class="terminal">/usr/lib/vmware-wcp/decryptK8Pwd.py</p>
<p><strong>Step 2</strong> - SSH to the IP Address provided in the previous step along with the password that was shown on the screen</p>
<p><strong>Step 3</strong> - Create your custom VM Class type YAML specification. Below are two examples called <strong>guaranteed-william.yaml</strong> and <strong>best-effort-william.yaml</strong> which shows how you can specify both reserved and non-reserved class type. You can always use <em>kubectl get vmclass &lt;name-of-class&gt; -o yaml</em> to see the existing definitions</p>
<p><strong>guaranteed-william.yaml</strong></p>
<div id="crayon-5f9c82e789815501196756" class="crayon-syntax crayon-theme-tomorrow-night crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Toggle Line Numbers"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Toggle Plain Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Open Code In New Window"><div class="crayon-button-icon"></div></div><span class="crayon-language">YAML</span></div></div>
<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
apiVersion: vmoperator.vmware.com/v1alpha1
kind: VirtualMachineClass
metadata:
  name: guaranteed-william
spec:
  hardware:
    cpus: 2
    memory: 6Gi
  policies:
    resources:
      requests:
        cpu: 2000m
        memory: 6Gi</textarea></div>
<div class="crayon-main" style="">
<table class="crayon-table">
<tr class="crayon-row">
<td class="crayon-nums " data-settings="show">
<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5f9c82e789815501196756-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e789815501196756-2">2</div><div class="crayon-num" data-line="crayon-5f9c82e789815501196756-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e789815501196756-4">4</div><div class="crayon-num" data-line="crayon-5f9c82e789815501196756-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e789815501196756-6">6</div><div class="crayon-num" data-line="crayon-5f9c82e789815501196756-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e789815501196756-8">8</div><div class="crayon-num" data-line="crayon-5f9c82e789815501196756-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e789815501196756-10">10</div><div class="crayon-num" data-line="crayon-5f9c82e789815501196756-11">11</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e789815501196756-12">12</div><div class="crayon-num" data-line="crayon-5f9c82e789815501196756-13">13</div></div>
</td>
<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5f9c82e789815501196756-1"><span class="crayon-s ">apiVersion</span><span class="">: vmoperator.vmware.com/v1alpha1</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e789815501196756-2"><span class="crayon-s ">kind</span><span class="">: VirtualMachineClass</span></div><div class="crayon-line" id="crayon-5f9c82e789815501196756-3"><span class="crayon-s ">metadata</span><span class="">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e789815501196756-4"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-s ">name</span><span class="">: guaranteed-william</span></div><div class="crayon-line" id="crayon-5f9c82e789815501196756-5"><span class="crayon-s ">spec</span><span class="">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e789815501196756-6"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-s ">hardware</span><span class="">:</span></div><div class="crayon-line" id="crayon-5f9c82e789815501196756-7"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">cpus</span><span class="">: 2</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e789815501196756-8"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">memory</span><span class="">: 6Gi</span></div><div class="crayon-line" id="crayon-5f9c82e789815501196756-9"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-s ">policies</span><span class="">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e789815501196756-10"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">resources</span><span class="">:</span></div><div class="crayon-line" id="crayon-5f9c82e789815501196756-11"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">requests</span><span class="">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e789815501196756-12"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">cpu</span><span class="">: 2000m</span></div><div class="crayon-line" id="crayon-5f9c82e789815501196756-13"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">memory</span><span class="">: 6Gi</span></div></div></td>
</tr>
</table>
</div>
</div>

<p><strong>best-effort-william.yaml</strong></p>
<div id="crayon-5f9c82e789818052331772" class="crayon-syntax crayon-theme-tomorrow-night crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Toggle Line Numbers"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Toggle Plain Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Open Code In New Window"><div class="crayon-button-icon"></div></div><span class="crayon-language">YAML</span></div></div>
<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
apiVersion: vmoperator.vmware.com/v1alpha1
kind: VirtualMachineClass
metadata:
  name: best-effort-william
spec:
  hardware:
    cpus: 2
    memory: 6Gi</textarea></div>
<div class="crayon-main" style="">
<table class="crayon-table">
<tr class="crayon-row">
<td class="crayon-nums " data-settings="show">
<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5f9c82e789818052331772-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e789818052331772-2">2</div><div class="crayon-num" data-line="crayon-5f9c82e789818052331772-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e789818052331772-4">4</div><div class="crayon-num" data-line="crayon-5f9c82e789818052331772-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e789818052331772-6">6</div><div class="crayon-num" data-line="crayon-5f9c82e789818052331772-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e789818052331772-8">8</div></div>
</td>
<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5f9c82e789818052331772-1"><span class="crayon-s ">apiVersion</span><span class="">: vmoperator.vmware.com/v1alpha1</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e789818052331772-2"><span class="crayon-s ">kind</span><span class="">: VirtualMachineClass</span></div><div class="crayon-line" id="crayon-5f9c82e789818052331772-3"><span class="crayon-s ">metadata</span><span class="">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e789818052331772-4"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-s ">name</span><span class="">: best-effort-william</span></div><div class="crayon-line" id="crayon-5f9c82e789818052331772-5"><span class="crayon-s ">spec</span><span class="">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e789818052331772-6"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-s ">hardware</span><span class="">:</span></div><div class="crayon-line" id="crayon-5f9c82e789818052331772-7"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">cpus</span><span class="">: 2</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e789818052331772-8"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">memory</span><span class="">: 6Gi</span></div></div></td>
</tr>
</table>
</div>
</div>

<p><strong>Step 4</strong> - To create our custom VM Class types, we need to run the following command and provide</p>
<p class="terminal">kubectl appy -f guaranteed-william.yaml<br />
kubectl appy -f best-effort-william.yaml</p>
<p><strong>Step 5</strong> - You can verify it was successfully created by running the following command:</p>
<p class="terminal">kubectl get vmclass</p>
<p><a href="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png?ssl=1" data-slb-active="1" data-slb-asset="826400880" data-slb-internal="0" data-slb-group="170248"><img data-attachment-id="170254" data-permalink="https://www.virtuallyghetto.com/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html/custom-virtual-machine-class-typs-vsphere-with-tanzu-1" data-orig-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png?fit=712%2C461&amp;ssl=1" data-orig-size="712,461" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="custom-virtual-machine-class-typs-vsphere-with-tanzu-1" data-image-description data-medium-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png?fit=300%2C194&amp;ssl=1" data-large-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png?fit=702%2C455&amp;ssl=1" loading="lazy" class="alignnone size-full wp-image-170254 jetpack-lazy-image" src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png?resize=702%2C455&#038;ssl=1" alt width="702" height="455" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png?w=712&amp;ssl=1 712w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png?resize=300%2C194&amp;ssl=1 300w" data-lazy-sizes="(max-width: 702px) 100vw, 702px" data-lazy-src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png?resize=702%2C455&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="170254" data-permalink="https://www.virtuallyghetto.com/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html/custom-virtual-machine-class-typs-vsphere-with-tanzu-1" data-orig-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png?fit=712%2C461&amp;ssl=1" data-orig-size="712,461" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="custom-virtual-machine-class-typs-vsphere-with-tanzu-1" data-image-description="" data-medium-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png?fit=300%2C194&amp;ssl=1" data-large-file="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png?fit=702%2C455&amp;ssl=1" loading="lazy" class="alignnone size-full wp-image-170254" src="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png?resize=702%2C455&#038;ssl=1" alt="" width="702" height="455" srcset="https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png?w=712&amp;ssl=1 712w, https://i2.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png?resize=300%2C194&amp;ssl=1 300w" sizes="(max-width: 702px) 100vw, 702px" data-recalc-dims="1" /></noscript></a><br />
At this point, you can logout of the Supervisor VM and vCenter and you are now ready to consume your new custom VM class.</p>
<p><strong>Step 6</strong> - If we take our TKG YAML example above and simply replace the class with our newly created VM class type called <strong>best-effort-william</strong></p>
<div id="crayon-5f9c82e78981a330183961" class="crayon-syntax crayon-theme-tomorrow-night crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Toggle Line Numbers"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Toggle Plain Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Open Code In New Window"><div class="crayon-button-icon"></div></div><span class="crayon-language">YAML</span></div></div>
<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
apiVersion: run.tanzu.vmware.com/v1alpha1
kind: TanzuKubernetesCluster
metadata:
  name: william-tkc-01
  namespace: primp-industries
spec:
  distribution:
    version: v1.17.8+vmware.1-tkg.1.5417466
  settings:
    network:
      cni:
        name: antrea
      pods:
        cidrBlocks:
        - 193.0.2.0/16
      serviceDomain: managedcluster.local
      services:
        cidrBlocks:
        - 195.51.100.0/12
  topology:
    controlPlane:
      class: best-effort-william
      count: 1
      storageClass: vsan-default-storage-policy
    workers:
      class: best-effort-william
      count: 3
      storageClass: vsan-default-storage-policy</textarea></div>
<div class="crayon-main" style="">
<table class="crayon-table">
<tr class="crayon-row">
<td class="crayon-nums " data-settings="show">
<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5f9c82e78981a330183961-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78981a330183961-2">2</div><div class="crayon-num" data-line="crayon-5f9c82e78981a330183961-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78981a330183961-4">4</div><div class="crayon-num" data-line="crayon-5f9c82e78981a330183961-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78981a330183961-6">6</div><div class="crayon-num" data-line="crayon-5f9c82e78981a330183961-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78981a330183961-8">8</div><div class="crayon-num" data-line="crayon-5f9c82e78981a330183961-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78981a330183961-10">10</div><div class="crayon-num" data-line="crayon-5f9c82e78981a330183961-11">11</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78981a330183961-12">12</div><div class="crayon-num" data-line="crayon-5f9c82e78981a330183961-13">13</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78981a330183961-14">14</div><div class="crayon-num" data-line="crayon-5f9c82e78981a330183961-15">15</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78981a330183961-16">16</div><div class="crayon-num" data-line="crayon-5f9c82e78981a330183961-17">17</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78981a330183961-18">18</div><div class="crayon-num" data-line="crayon-5f9c82e78981a330183961-19">19</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78981a330183961-20">20</div><div class="crayon-num" data-line="crayon-5f9c82e78981a330183961-21">21</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78981a330183961-22">22</div><div class="crayon-num" data-line="crayon-5f9c82e78981a330183961-23">23</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78981a330183961-24">24</div><div class="crayon-num" data-line="crayon-5f9c82e78981a330183961-25">25</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78981a330183961-26">26</div><div class="crayon-num" data-line="crayon-5f9c82e78981a330183961-27">27</div><div class="crayon-num crayon-striped-num" data-line="crayon-5f9c82e78981a330183961-28">28</div></div>
</td>
<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5f9c82e78981a330183961-1"><span class="crayon-s ">apiVersion</span><span class="">: run.tanzu.vmware.com/v1alpha1</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78981a330183961-2"><span class="crayon-s ">kind</span><span class="">: TanzuKubernetesCluster</span></div><div class="crayon-line" id="crayon-5f9c82e78981a330183961-3"><span class="crayon-s ">metadata</span><span class="">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78981a330183961-4"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-s ">name</span><span class="">: william-tkc-01</span></div><div class="crayon-line" id="crayon-5f9c82e78981a330183961-5"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-s ">namespace</span><span class="">: primp-industries</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78981a330183961-6"><span class="crayon-s ">spec</span><span class="">:</span></div><div class="crayon-line" id="crayon-5f9c82e78981a330183961-7"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-s ">distribution</span><span class="">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78981a330183961-8"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">version</span><span class="">: v1.17.8+vmware.1-tkg.1.5417466</span></div><div class="crayon-line" id="crayon-5f9c82e78981a330183961-9"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-s ">settings</span><span class="">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78981a330183961-10"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">network</span><span class="">:</span></div><div class="crayon-line" id="crayon-5f9c82e78981a330183961-11"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">cni</span><span class="">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78981a330183961-12"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">name</span><span class="">: antrea</span></div><div class="crayon-line" id="crayon-5f9c82e78981a330183961-13"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">pods</span><span class="">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78981a330183961-14"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">cidrBlocks</span><span class="">:</span></div><div class="crayon-line" id="crayon-5f9c82e78981a330183961-15"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span>-<span class="crayon-h"> </span>193<span class="crayon-o">.</span>0<span class="crayon-o">.</span>2<span class="crayon-o">.</span>0/16</div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78981a330183961-16"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">serviceDomain</span><span class="">: managedcluster.local</span></div><div class="crayon-line" id="crayon-5f9c82e78981a330183961-17"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">services</span><span class="">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78981a330183961-18"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">cidrBlocks</span><span class="">:</span></div><div class="crayon-line" id="crayon-5f9c82e78981a330183961-19"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span>-<span class="crayon-h"> </span>195<span class="crayon-o">.</span>51<span class="crayon-o">.</span>100<span class="crayon-o">.</span>0/12</div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78981a330183961-20"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-s ">topology</span><span class="">:</span></div><div class="crayon-line" id="crayon-5f9c82e78981a330183961-21"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">controlPlane</span><span class="">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78981a330183961-22"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">class</span><span class="">: best-effort-william</span></div><div class="crayon-line" id="crayon-5f9c82e78981a330183961-23"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">count</span><span class="">: 1</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78981a330183961-24"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">storageClass</span><span class="">: vsan-default-storage-policy</span></div><div class="crayon-line" id="crayon-5f9c82e78981a330183961-25"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">workers</span><span class="">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78981a330183961-26"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">class</span><span class="">: best-effort-william</span></div><div class="crayon-line" id="crayon-5f9c82e78981a330183961-27"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">count</span><span class="">: 3</span></div><div class="crayon-line crayon-striped-line" id="crayon-5f9c82e78981a330183961-28"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-s ">storageClass</span><span class="">: vsan-default-storage-policy</span></div></div></td>
</tr>
</table>
</div>
</div>

<p>and then run the following command to deploy our TKG Cluster:</p>
<p class="terminal">kubectl apply -f william.yaml</p>
<p>We should see the deployment start and if we look at the CPU/Memory, we should now see it matches our custom VM class type</p>
<p><a href="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?ssl=1" data-slb-active="1" data-slb-asset="1058566139" data-slb-internal="0" data-slb-group="170248"><img data-attachment-id="170255" data-permalink="https://www.virtuallyghetto.com/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html/custom-virtual-machine-class-typs-vsphere-with-tanzu-2" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?fit=1249%2C665&amp;ssl=1" data-orig-size="1249,665" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="custom-virtual-machine-class-typs-vsphere-with-tanzu-2" data-image-description data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?fit=300%2C160&amp;ssl=1" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?fit=702%2C374&amp;ssl=1" loading="lazy" class="alignnone size-large wp-image-170255 jetpack-lazy-image" src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?resize=702%2C374&#038;ssl=1" alt width="702" height="374" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?resize=1024%2C545&amp;ssl=1 1024w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?resize=300%2C160&amp;ssl=1 300w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?resize=768%2C409&amp;ssl=1 768w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?w=1249&amp;ssl=1 1249w" data-lazy-sizes="(max-width: 702px) 100vw, 702px" data-lazy-src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?resize=702%2C374&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="170255" data-permalink="https://www.virtuallyghetto.com/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html/custom-virtual-machine-class-typs-vsphere-with-tanzu-2" data-orig-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?fit=1249%2C665&amp;ssl=1" data-orig-size="1249,665" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="custom-virtual-machine-class-typs-vsphere-with-tanzu-2" data-image-description="" data-medium-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?fit=300%2C160&amp;ssl=1" data-large-file="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?fit=702%2C374&amp;ssl=1" loading="lazy" class="alignnone size-large wp-image-170255" src="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?resize=702%2C374&#038;ssl=1" alt="" width="702" height="374" srcset="https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?resize=1024%2C545&amp;ssl=1 1024w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?resize=300%2C160&amp;ssl=1 300w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?resize=768%2C409&amp;ssl=1 768w, https://i0.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png?w=1249&amp;ssl=1 1249w" sizes="(max-width: 702px) 100vw, 702px" data-recalc-dims="1" /></noscript></a></p>
<p><a href="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?ssl=1" data-slb-active="1" data-slb-asset="1759988226" data-slb-internal="0" data-slb-group="170248"><img data-attachment-id="170256" data-permalink="https://www.virtuallyghetto.com/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html/custom-virtual-machine-class-typs-vsphere-with-tanzu-3" data-orig-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?fit=1339%2C551&amp;ssl=1" data-orig-size="1339,551" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="custom-virtual-machine-class-typs-vsphere-with-tanzu-3" data-image-description data-medium-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?fit=300%2C123&amp;ssl=1" data-large-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?fit=702%2C289&amp;ssl=1" loading="lazy" class="alignnone size-large wp-image-170256 jetpack-lazy-image" src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?resize=702%2C289&#038;ssl=1" alt width="702" height="289" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?resize=1024%2C421&amp;ssl=1 1024w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?resize=300%2C123&amp;ssl=1 300w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?resize=768%2C316&amp;ssl=1 768w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?w=1339&amp;ssl=1 1339w" data-lazy-sizes="(max-width: 702px) 100vw, 702px" data-lazy-src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?resize=702%2C289&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="170256" data-permalink="https://www.virtuallyghetto.com/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html/custom-virtual-machine-class-typs-vsphere-with-tanzu-3" data-orig-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?fit=1339%2C551&amp;ssl=1" data-orig-size="1339,551" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="custom-virtual-machine-class-typs-vsphere-with-tanzu-3" data-image-description="" data-medium-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?fit=300%2C123&amp;ssl=1" data-large-file="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?fit=702%2C289&amp;ssl=1" loading="lazy" class="alignnone size-large wp-image-170256" src="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?resize=702%2C289&#038;ssl=1" alt="" width="702" height="289" srcset="https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?resize=1024%2C421&amp;ssl=1 1024w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?resize=300%2C123&amp;ssl=1 300w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?resize=768%2C316&amp;ssl=1 768w, https://i1.wp.com/www.virtuallyghetto.com/wp-content/uploads/2020/10/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png?w=1339&amp;ssl=1 1339w" sizes="(max-width: 702px) 100vw, 702px" data-recalc-dims="1" /></noscript></a></p>
<div class="wp_rp_wrap  wp_rp_vertical_m" id="wp_rp_first"><div class="wp_rp_content"><h3 class="related_post_title">More from my site</h3><ul class="related_post wp_rp"><li data-position="0" data-poid="in-169874" data-post-type="none"><a href="https://www.virtuallyghetto.com/2020/10/automating-workload-management-on-vsphere-with-tanzu.html" class="wp_rp_title">Automating Workload Management on vSphere with Tanzu</a></li><li data-position="1" data-poid="in-169762" data-post-type="none"><a href="https://www.virtuallyghetto.com/2020/10/automated-vsphere-with-tanzu-lab-deployment-script.html" class="wp_rp_title">Automated vSphere with Tanzu Lab Deployment Script</a></li><li data-position="2" data-poid="in-169680" data-post-type="none"><a href="https://www.virtuallyghetto.com/2020/10/how-to-ssh-to-tanzu-kubernetes-grid-tkg-cluster-in-vsphere-with-tanzu.html" class="wp_rp_title">How to SSH to Tanzu Kubernetes Grid (TKG) Cluster in vSphere with Tanzu?</a></li><li data-position="3" data-poid="in-7212" data-post-type="none"><a href="https://www.virtuallyghetto.com/2011/09/how-to-automate-deployment.html" class="wp_rp_title">How to Automate the Deployment &amp; Configuration of vShield Manager 5</a></li><li data-position="4" data-poid="in-167475" data-post-type="none"><a href="https://www.virtuallyghetto.com/2020/03/integrating-vcenter-event-broker-appliance-veba-with-vrealize-orchestrator.html" class="wp_rp_title">Integrating vCenter Event Broker Appliance (VEBA) with vRealize Orchestrator </a></li></ul></div></div>
<div class="ssba-modern-2 ssba ssbp-wrap left ssbp--theme-1"><div style="text-align:left"><span class="ssba-share-text">Share this...</span><br /><ul class="ssbp-list"><li class="ssbp-li--twitter"><a data-site="" class="ssba_twitter_share ssbp-twitter ssbp-btn" href="https://twitter.com/share?url=https://www.virtuallyghetto.com/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html&amp;text=Custom%20Virtual%20Machine%20Class%20Types%20with%20vSphere%20with%20Tanzu%20" target=&quot;_blank&quot;><div title="Twitter" class="ssbp-text">Twitter</div></a></li><li class="ssbp-li--facebook"><a data-site="" class="ssba_facebook_share ssbp-facebook ssbp-btn" href="https://www.facebook.com/sharer.php?u=https://www.virtuallyghetto.com/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html" target="_blank"><div title="Facebook" class="ssbp-text">Facebook</div></a></li><li class="ssbp-li--linkedin"><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link ssbp-linkedin ssbp-btn" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.virtuallyghetto.com/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html" target=&quot;_blank&quot;><div title="Linkedin" class="ssbp-text">Linkedin</div></a></li><li class="ssbp-li--reddit"><a data-site="reddit" class="ssba_reddit_share ssbp-reddit ssbp-btn" href="https://reddit.com/submit?url=https://www.virtuallyghetto.com/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html&amp;title=Custom Virtual Machine Class Types with vSphere with Tanzu" target=&quot;_blank&quot;><div title="Reddit" class="ssbp-text">Reddit</div></a></li><li class="ssbp-li--pinterest"><a data-site='pinterest' class='ssba_pinterest_share ssbp-pinterest ssbp-btn' href='javascript:void((function()%7Bvar%20e=document.createElement(&apos;script&apos;);e.setAttribute(&apos;type&apos;,&apos;text/javascript&apos;);e.setAttribute(&apos;charset&apos;,&apos;UTF-8&apos;);e.setAttribute(&apos;src&apos;,&apos;//assets.pinterest.com/js/pinmarklet.js?r=&apos;+Math.random()*99999999);document.body.appendChild(e)%7D)());'><div title="Pinterest" class="ssbp-text">Pinterest</div></a></li></ul></div></div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://www.virtuallyghetto.com/category/kubernetes" rel="category tag">Kubernetes</a>, <a href="https://www.virtuallyghetto.com/category/vmware-tanzu" rel="category tag">VMware Tanzu</a></span> <span class="entry-tags">Tagged With: <a href="https://www.virtuallyghetto.com/tag/vsphere-with-tanzu" rel="tag">vSphere with Tanzu</a></span></p></footer></article><h2 class="screen-reader-text">Reader Interactions</h2>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Thanks for the comment! <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/10/custom-virtual-machine-class-types-with-vsphere-with-tanzu.html#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=67295360&#038;postid=170248&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=retro&#038;greeting=Thanks+for+the+comment%21&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=transparent&#038;lang=en_US&#038;jetpack_version=9.0.2&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=cf8318256d0387ffbb5336bf80dccfe457177ca9#parent=https%3A%2F%2Fwww.virtuallyghetto.com%2F2020%2F10%2Fcustom-virtual-machine-class-types-with-vsphere-with-tanzu.html" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = true;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="search-7" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://www.virtuallyghetto.com/" role="search" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction"><label class="search-form-label screen-reader-text" for="searchform-1">Search this website</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website" itemprop="query-input"><input class="search-form-submit" type="submit" value="Search"><meta content="https://www.virtuallyghetto.com/?s={s}" itemprop="target"></form></div></section>
<section id="user-profile-9" class="widget user-profile"><div class="widget-wrap"><h3 class="widgettitle widget-title">Author</h3>
<p><span class="alignleft"><img class="avatar avatar-125 photo jetpack-lazy-image" width="64" height="64" src="https://www.virtuallyghetto.com/wp-content/uploads/2017/01/292c324.jpg" data-lazy-src="https://www.virtuallyghetto.com/wp-content/uploads/2017/01/292c324.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="avatar avatar-125 photo" width="64" height="64" src="https://www.virtuallyghetto.com/wp-content/uploads/2017/01/292c324.jpg"/></noscript></span>William Lam is a Senior Staff Solution Architect working in the VMware Cloud team within the Cloud Services Business Unit (CSBU) at VMware. He focuses on Automation, Integration and Operation of the VMware Software Defined Datacenter (SDDC).</p>
</div></section>
<section id="simple-social-icons-4" class="widget simple-social-icons"><div class="widget-wrap"><ul class="aligncenter"><li class="ssi-email"><a href="/cdn-cgi/l/email-protection#9eb8bdafaeaba5b8bdafafaea5b8bdafaeaca5b8bdafafafa5b8bdaeaaa8a5b8bdafafa6a5f7b8bdafafaaa5b8bdafafa8a5ebb8bdaea7a9a5f2b8bdafaea6a5b8bdafacafa5f9b8bdafaeaaa5b8bdafaeafa5b8bdafafa8a5b8bdafafa8a5b8bdafafafa5b8bdaea8aaa5f9b8bdafaea7a5b8bdaea7a9a5f7f2b0fdb8bdafafafa5f3"><svg role="img" class="social-email" aria-labelledby="social-email-4"><title id="social-email-4">Email</title><use xlink:href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-email"></use></svg></a></li><li class="ssi-github"><a href="https://github.com/lamw" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-github" aria-labelledby="social-github-4"><title id="social-github-4">GitHub</title><use xlink:href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-github"></use></svg></a></li><li class="ssi-linkedin"><a href="https://www.linkedin.com/in/lamwilliam/" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-linkedin" aria-labelledby="social-linkedin-4"><title id="social-linkedin-4">LinkedIn</title><use xlink:href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-linkedin"></use></svg></a></li><li class="ssi-rss"><a href="https://www.virtuallyghetto.com/rss" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-rss" aria-labelledby="social-rss-4"><title id="social-rss-4">RSS</title><use xlink:href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-rss"></use></svg></a></li><li class="ssi-twitter"><a href="https://twitter.com/lamw" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-twitter" aria-labelledby="social-twitter-4"><title id="social-twitter-4">Twitter</title><use xlink:href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li><li class="ssi-vimeo"><a href="https://vimeo.com/virtuallyghetto" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-vimeo" aria-labelledby="social-vimeo-4"><title id="social-vimeo-4">Vimeo</title><use xlink:href="https://www.virtuallyghetto.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-vimeo"></use></svg></a></li></ul></div></section>
<section id="bsa-6" class="widget widget_bsa"><div class="widget-wrap"><h3 class="widgettitle widget-title">Sponsors</h3>

<div id="bsap_1282588" class="bsarocks bsap_6d274f0434e88e8f84574d74902bc1c4"></div>

</div></section>
<section id="eu_cookie_law_widget-2" class="widget widget_eu_cookie_law_widget"><div class="widget-wrap">
<div class="hide-on-button negative" data-hide-timeout="30" data-consent-expiration="180" id="eu-cookie-law">
<form method="post">
<input type="submit" value="Close and accept" class="accept" />
</form>
Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br /> 
To find out more, including how to control cookies, see here:
<a href="https://www.virtuallyghetto.com/privacy-policy" rel="">
Cookie Policy	</a>
</div>
</div></section>
</aside></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"></div></footer></div> <div style="display:none">
<div class="grofile-hash-map-b9d29da4e111863744d8421dc0801219">
</div>
</div>
<style type="text/css" media="screen"> #simple-social-icons-4 ul li a, #simple-social-icons-4 ul li a:hover, #simple-social-icons-4 ul li a:focus { background-color: #000000 !important; border-radius: 6px; color: #ffffff !important; border: 0px #ffffff solid !important; font-size: 18px; padding: 9px; }  #simple-social-icons-4 ul li a:hover, #simple-social-icons-4 ul li a:focus { background-color: #830101 !important; border-color: #ffffff !important; color: #ffffff !important; }  #simple-social-icons-4 ul li a:focus { outline: 1px dotted #830101 !important; }</style><link rel='stylesheet' id='simple-share-buttons-adder-ssba-css' href='https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=5.5.2' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
.ssba img
								{border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}

								.ssba-classic-2 .ssbp-text {
									display: none!important;
								}
					.ssbp-list li a {height: 32px!important; width: 32px!important; 
					}
					.ssbp-list li a:hover {
					}

					.ssbp-list li a::before {line-height: 32px!important;; font-size: 24px;}
					.ssbp-list li a:hover::before {}
					.ssbp-list li {
					margin-left: 12px!important;
					}

					.ssba-share-text {
					font-size: 14px;  font-weight: normal; font-family: inherit;
						}

			   #ssba-bar-2 .ssbp-bar-list {
					max-width: 48px!important;;
			   }
			   #ssba-bar-2 .ssbp-bar-list li a {height: 48px!important; width: 48px!important; 
				}
				#ssba-bar-2 .ssbp-bar-list li a:hover {
				}

				#ssba-bar-2 .ssbp-bar-list li a::before {line-height: 48px!important;; font-size: 18px;}
				#ssba-bar-2 .ssbp-bar-list li a:hover::before {}
				#ssba-bar-2 .ssbp-bar-list li {
				margin: 0px 0!important;
				}@media only screen and ( max-width: 750px ) {
				#ssba-bar-2 {
				display: block;
				}
			}
@font-face {
				font-family: 'ssbp';
				src:url('https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?xj3ol1');
				src:url('https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?#iefixxj3ol1') format('embedded-opentype'),
					url('https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.woff?xj3ol1') format('woff'),
					url('https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.ttf?xj3ol1') format('truetype'),
					url('https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.svg?xj3ol1#ssbp') format('svg');
				font-weight: normal;
				font-style: normal;

				/* Better Font Rendering =========== */
				-webkit-font-smoothing: antialiased;
				-moz-osx-font-smoothing: grayscale;
			}
</style>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script type='text/javascript' id='eeb-js-ajax-ef-js-extra'>
/* <![CDATA[ */
var eeb_ef = {"ajaxurl":"https:\/\/www.virtuallyghetto.com\/wp-admin\/admin-ajax.php","security":"3ca3f5ad43"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/email-encoder-bundle/core/includes/assets/js/encoder-form.js?ver=201012-130506' id='eeb-js-ajax-ef-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.js?ver=5.5.2' id='simple-share-buttons-adder-ssba-js'></script>
<script type='text/javascript' id='simple-share-buttons-adder-ssba-js-after'>
Main.boot( [] );
</script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202044' id='grofiles-cards-js'></script>
<script type='text/javascript' id='wpgroho-js-extra'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=9.0.2' id='wpgroho-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-includes/js/comment-reply.min.js?ver=5.5.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1' id='hoverIntent-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10' id='superfish-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=3.3.3' id='superfish-args-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=3.3.3' id='skip-links-js'></script>
<script type='text/javascript' id='genesis-sample-responsive-menu-js-extra'>
/* <![CDATA[ */
var genesis_responsive_menu = {"mainMenu":"Menu","menuIconClass":"dashicons-before dashicons-menu","subMenu":"Submenu","subMenuIconClass":"dashicons-before dashicons-arrow-down-alt2","menuClasses":{"combine":[".nav-primary"],"others":[]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/themes/genesis-sample/js/responsive-menus.min.js?ver=2.6.0' id='genesis-sample-responsive-menu-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/themes/genesis-sample/js/genesis-sample.js?ver=2.6.0' id='genesis-sample-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js?ver=20180522' id='eu-cookie-law-script-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.0.0' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-includes/js/wp-embed.min.js?ver=5.5.2' id='wp-embed-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.virtuallyghetto.com\/wp-admin\/admin-ajax.php","nonce":"47fc070078","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.virtuallyghetto.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.virtuallyghetto.com%2F2020%2F10%2Fcustom-virtual-machine-class-types-with-vsphere-with-tanzu.html","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=9.0.2' id='jetpack-carousel-js'></script>
<script async="async" type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.7' id='akismet-form-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/client/js/prod/lib.core.js?ver=2.8.1' id='slb_core-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/client/js/prod/lib.view.js?ver=2.8.1' id='slb_view-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/themes/baseline/js/prod/client.js?ver=2.8.1' id='slb-asset-slb_baseline-base-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/themes/default/js/prod/client.js?ver=2.8.1' id='slb-asset-slb_default-base-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/template-tags/item/js/prod/tag.item.js?ver=2.8.1' id='slb-asset-item-base-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/template-tags/ui/js/prod/tag.ui.js?ver=2.8.1' id='slb-asset-ui-base-js'></script>
<script type='text/javascript' src='https://www.virtuallyghetto.com/wp-content/plugins/simple-lightbox/content-handlers/image/js/prod/handler.image.js?ver=2.8.1' id='slb-asset-image-base-js'></script>
<script type="text/javascript" id="slb_footer">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB && SLB.has_child('View.init') ) { SLB.View.init({"ui_autofit":true,"ui_animate":true,"slideshow_autostart":true,"slideshow_duration":"6","group_loop":true,"ui_overlay_opacity":"0.8","ui_title_default":false,"theme_default":"slb_default","ui_labels":{"loading":"Loading","close":"Close","nav_next":"Next","nav_prev":"Previous","slideshow_start":"Start slideshow","slideshow_stop":"Stop slideshow","group_status":"Item %current% of %total%"}}); }
if ( !!window.SLB && SLB.has_child('View.assets') ) { {$.extend(SLB.View.assets, {"53153685":{"id":170251,"type":"image","internal":true,"source":"https:\/\/www.virtuallyghetto.com\/wp-content\/uploads\/2020\/10\/custom-virtual-machine-class-typs-vsphere-with-tanzu-0.png","title":"custom-virtual-machine-class-typs-vsphere-with-tanzu-0","caption":"","description":""},"826400880":{"id":170254,"type":"image","internal":true,"source":"https:\/\/www.virtuallyghetto.com\/wp-content\/uploads\/2020\/10\/custom-virtual-machine-class-typs-vsphere-with-tanzu-1.png","title":"custom-virtual-machine-class-typs-vsphere-with-tanzu-1","caption":"","description":""},"1058566139":{"id":170255,"type":"image","internal":true,"source":"https:\/\/www.virtuallyghetto.com\/wp-content\/uploads\/2020\/10\/custom-virtual-machine-class-typs-vsphere-with-tanzu-2.png","title":"custom-virtual-machine-class-typs-vsphere-with-tanzu-2","caption":"","description":""},"1759988226":{"id":170256,"type":"image","internal":true,"source":"https:\/\/www.virtuallyghetto.com\/wp-content\/uploads\/2020\/10\/custom-virtual-machine-class-typs-vsphere-with-tanzu-3.png","title":"custom-virtual-machine-class-typs-vsphere-with-tanzu-3","caption":"","description":""}});} }
/* THM */
if ( !!window.SLB && SLB.has_child('View.extend_theme') ) { SLB.View.extend_theme('slb_baseline',{"name":"Baseline","parent":"","styles":[{"handle":"base","uri":"https:\/\/www.virtuallyghetto.com\/wp-content\/plugins\/simple-lightbox\/themes\/baseline\/css\/style.css","deps":[]}],"layout_raw":"<div class=\"slb_container\"><div class=\"slb_content\">{{item.content}}<div class=\"slb_nav\"><span class=\"slb_prev\">{{ui.nav_prev}}<\/span><span class=\"slb_next\">{{ui.nav_next}}<\/span><\/div><div class=\"slb_controls\"><span class=\"slb_close\">{{ui.close}}<\/span><span class=\"slb_slideshow\">{{ui.slideshow_control}}<\/span><\/div><div class=\"slb_loading\">{{ui.loading}}<\/div><\/div><div class=\"slb_details\"><div class=\"inner\"><div class=\"slb_data\"><div class=\"slb_data_content\"><span class=\"slb_data_title\">{{item.title}}<\/span><span class=\"slb_group_status\">{{ui.group_status}}<\/span><div class=\"slb_data_desc\">{{item.description}}<\/div><\/div><\/div><div class=\"slb_nav\"><span class=\"slb_prev\">{{ui.nav_prev}}<\/span><span class=\"slb_next\">{{ui.nav_next}}<\/span><\/div><\/div><\/div><\/div>"}); }if ( !!window.SLB && SLB.has_child('View.extend_theme') ) { SLB.View.extend_theme('slb_default',{"name":"Default (Light)","parent":"slb_baseline","styles":[{"handle":"base","uri":"https:\/\/www.virtuallyghetto.com\/wp-content\/plugins\/simple-lightbox\/themes\/default\/css\/style.css","deps":[]}]}); }})})(jQuery);}/* ]]> */</script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=67295360&postid=170248&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=retro&greeting=Thanks+for+the+comment%21&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=9.0.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=cf8318256d0387ffbb5336bf80dccfe457177ca9#parent=https%3A%2F%2Fwww.virtuallyghetto.com%2F2020%2F10%2Fcustom-virtual-machine-class-types-with-vsphere-with-tanzu.html" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=67295360&postid=170248&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=retro&greeting=Thanks+for+the+comment%21&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=9.0.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=cf8318256d0387ffbb5336bf80dccfe457177ca9#parent=https%3A%2F%2Fwww.virtuallyghetto.com%2F2020%2F10%2Fcustom-virtual-machine-class-types-with-vsphere-with-tanzu.html";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script type='text/javascript' src='https://stats.wp.com/e-202044.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.0.2',blog:'67295360',post:'170248',tz:'-7',srv:'www.virtuallyghetto.com'} ]);
	_stq.push([ 'clickTrackerInit', '67295360', '170248' ]);
</script>
</body></html>
